Wikipedia.org: add app links to Portal dashboard
Closed, ResolvedPublic4 Story Points

Description

As the long term test of the addition of the Wikipedia / Wikimedia app links to the Wikipedia.org portal page is winding down and all signs are showing that the addition of the links have been successfully aiding in the discovery (for our visitors) that there are Wikipedia mobile apps, we'd like to go ahead and make it a permanent part of the portal page.

Based on the test that was detailed here (T137495) and test results detailed here (T146807), let's go ahead and add the clicks to all the app links to our Portal Dashboard Engagement section: http://discovery.wmflabs.org/portal/

Let's break up the desktop vs mobile clicks into individual lines and also separate out the iOS, Android and list of apps page clicks to easily display which type of device and which app link was clicked on.

We can also have a total number (can be a checkbox that is clicked to activate) that displays total clickthroughs for any and all click on the app links.

debt created this task.Jan 4 2017, 11:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 4 2017, 11:59 PM

[ Please add Wikimedia-Portals if a task is about the Wikimedia-Portals code base or config. Thanks! ]

debt updated the task description. (Show Details)Jan 6 2017, 12:07 AM

I posted this question at T138877#2922421 before realizing that there are many Maniphest tasks about portal concerns in the same number range, so I'll ask again here, in a vaguely more centralized spot.

Have the various concerns raised at https://www.mediawiki.org/wiki/Talk:Wikipedia.org_add_mobile_app_badges been addressed?

Oh, nope, this task is about the portal dashboard. I want T135441: [EPIC] Wikipedia.org Portal: add app download badge, I think.

debt added a comment.Jan 9 2017, 7:01 PM

Hi @MZMcBride, yes, I believe that all the concerns have been addressed in the various tickets that were opened as a subtask of the epic ticket T135441 and in the comments on the talk page.

Please let me know if something hasn't been answered to satisfaction.

chelsyx claimed this task.Jan 18 2017, 6:05 PM
chelsyx moved this task from Backlog to In progress on the Discovery-Analysis (Current work) board.
mpopov claimed this task.Jan 24 2017, 11:07 PM
mpopov set the point value for this task to 4.

Change 325870 had a related patch set uploaded (by Bearloga):
Migrate to Reportupdater framework

https://gerrit.wikimedia.org/r/325870

Change 336350 had a related patch set uploaded (by Bearloga):
Point to new datasets & add new metrics

https://gerrit.wikimedia.org/r/336350

Change 336350 merged by Bearloga:
Point to new datasets & add new metrics

https://gerrit.wikimedia.org/r/336350

debt added a comment.Feb 8 2017, 4:25 PM

Interesting! :) Can the clicks and date numbers be a lighter color to more easily see them? Thanks!

mpopov added a comment.Feb 8 2017, 7:50 PM

@debt: the dark axes is a known bug that we can't reproduce / don't know what causes it :\ if you click on a different dashboard and then go back to the sister projects one, it should be white

Change 325870 merged by Bearloga:
[wikimedia/discovery/golden] Migrate to Reportupdater framework

https://gerrit.wikimedia.org/r/325870

debt closed this task as Resolved.Mar 16 2017, 12:38 PM