Page MenuHomePhabricator

[EPIC] Deploy page previews to English and German Wikipedia
Closed, ResolvedPublic

Description

Acceptance criteria

  • Subtasks should be resolved.

Note: The remaining subtasks relating to the VirtualPageViews have been bundled under T192622. Although not resolved they are not forgotten.

  • Page previews should be enabled on German and English Wikipedia
  • Extracts in summaries of these wikis should be in HTML

Sign off steps

Update the mediawiki.org documentation to include changes to the preferences page relating to the addition of hovercards preferences.

This should only happen when Page previews is deployed to English Wikipedia

Related Objects

StatusAssignedTask
OpenNone
Resolvedmforns
Resolvedovasileva
ResolvedJdlrobson
DuplicateNone
DuplicateNone
Resolvedovasileva
Resolvedovasileva
ResolvedDereckson
ResolvedJdlrobson
Resolvedovasileva
Resolvedovasileva
Resolved Tbayer
Resolved Tbayer
Resolved Tbayer
Resolved Tbayer
Resolved Tbayer
Resolvedphuedx
ResolvedJdlrobson
Resolved Tbayer
Declined Tbayer
Declined Tbayer
Resolvedphuedx
Resolved Tbayer
Resolvedpmiazga
Resolved Tbayer
Resolvedphuedx
Resolvedpmiazga
Resolvedphuedx
Resolvedovasileva
Resolvedphuedx
Resolvedphuedx
Resolvedovasileva
Resolvedphuedx
Resolvedphuedx
DuplicateNone
ResolvedJdlrobson
ResolvedJdlrobson
DuplicateNone
Duplicateovasileva
Resolvedovasileva
DuplicateNone
DeclinedNone
DuplicateJdlrobson
ResolvedMhurd
DeclinedJMinor
Resolvedphuedx
ResolvedPchelolo
ResolvedJdlrobson
DeclinedPchelolo
DeclinedNone
OpenNone
Resolvedphuedx
DeclinedJdlrobson
DuplicateNone
ResolvedFjalapeno
Resolvedphuedx
Declinedpmiazga
Resolvedphuedx
DeclinedNone
ResolvedPchelolo
ResolvedbearND
ResolvedMholloway
ResolvedMSantos
ResolvedMholloway
InvalidNone
ResolvedJdlrobson
InvalidNone
DuplicateNone
ResolvedbearND
ResolvedMholloway
DuplicateNone
ResolvedJdlrobson
ResolvedJdlrobson
Resolvedphuedx
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedbearND
ResolvedJdlrobson
ResolvedMholloway
ResolvedMholloway
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedbearND
ResolvedCKoerner_WMF
Resolvedovasileva
ResolvedABorbaWMF
Resolvedmobrovac
ResolvedABorbaWMF
ResolvedABorbaWMF
ResolvedMholloway
ResolvedMholloway
OpenNone
ResolvedMholloway
Resolvedovasileva
ResolvedbearND
OpenNone
DeclinedNone
OpenNone
OpenNone
Resolvedovasileva
DuplicateNone
ResolvedNone
Resolvedovasileva
ResolvedNone
Resolvedmforns
Resolvedphuedx
DeclinedNone
Resolved Tbayer
Resolvedovasileva
Resolved Tbayer
DuplicateNone
DeclinedNone
ResolvedNirzar
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
ResolvedJdlrobson
Resolvedphuedx
ResolvedNuria
ResolvedNone
Resolvedovasileva
Resolved Tbayer

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 5 2017, 12:00 AM
ovasileva triaged this task as High priority.Jan 5 2017, 5:06 PM
ovasileva moved this task from To Triage to Product Owner Backlog on the Readers-Web-Backlog board.
Jdlrobson added a subscriber: Jdlrobson.

Olga.. what does this mean?

When we deploy page previews, we should update the documentation for user preferences page to note the addition of the page previews section in preferences

Where is said documentation?

Ping. An updates on this?

ovasileva lowered the priority of this task from High to Normal.May 30 2017, 2:37 PM

https://www.mediawiki.org/wiki/Help:Preferences - not sure why I marked this as high, we shouldn't update until we deploy on English

Jdlrobson renamed this task from Update documentation for changes to preferences page to Deploy page previews to English and German Wikipedia.Jul 12 2017, 3:34 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)
ovasileva renamed this task from Deploy page previews to English and German Wikipedia to [EPIC] Deploy page previews to English and German Wikipedia.Dec 7 2017, 12:33 PM
ovasileva added a project: Epic.
ovasileva moved this task from Backlog to Next Up on the Page-Previews board.Dec 12 2017, 3:51 PM
Niedzielski added a subscriber: Niedzielski.

I've added T184534 as a blocker to this deployment until we can at least know how widespread the issue is.

Jdlrobson changed the task status from Stalled to Open.Feb 22 2018, 10:16 PM

This doesn't look stalled anymore now the summary endpoint is live, the fate is in our hands.

Jdlrobson changed the status of subtask T173952: Remove A/B testing instrumentation code from Stalled to Open.Mar 29 2018, 11:57 PM
ovasileva updated the task description. (Show Details)Apr 19 2018, 8:47 AM
Jdlrobson closed this task as Resolved.Apr 20 2018, 1:05 AM

I have ticked the last box "Subtasks should be resolved." after reviewing the remaining 3 subtasks.

T184793 [EPIC] Instrument page interactions and friends have been moved under T192622 to continue this journey. I've checked in with Tilman and although analysis is still going on there, it doesn't seem to block resolving this task which was about deploying page previews.

Good work all!