Page MenuHomePhabricator

[Regression pre-wmf.8] "Categories" section is accessible from Options in NWE although it's disabled in the menu
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Open NWE
  2. Click on the Options icon
  3. Click on the first option in the menu "Options" (since it appears enabled now).

It opens the Categories section , even though in the main menu it is disabled.

Event Timeline

Ryasmeen created this task.Jan 5 2017, 1:03 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 5 2017, 1:03 AM
Jdforrester-WMF triaged this task as High priority.Jan 5 2017, 4:30 PM
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

Changing summary since we moved Categories to the top in the menu

Ryasmeen renamed this task from [Regression pre-wmf.8] "Page Settings" section is accessible from Options in NWE although it's disabled in the menu to [Regression pre-wmf.8] "Categories" section is accessible from Options in NWE although it's disabled in the menu.Jan 10 2017, 10:35 PM
Ryasmeen updated the task description. (Show Details)
Jdforrester-WMF set the point value for this task to 1.Jan 16 2017, 8:03 PM

Change 332389 had a related patch set uploaded (by Jforrester):
MWMetaDialogTool: In source mode, disable the "Options" tool too.

https://gerrit.wikimedia.org/r/332389

Change 332414 had a related patch set uploaded (by Esanders):
Fix correct default page for meta dialog in NWE

https://gerrit.wikimedia.org/r/332414

Change 332389 abandoned by Jforrester:
MWMetaDialogTool: In source mode, disable the "Options" tool too.

Reason:
Ed's fix is better.

https://gerrit.wikimedia.org/r/332389

Change 332414 merged by jenkins-bot:
Fix correct default page for meta dialog in NWE

https://gerrit.wikimedia.org/r/332414

Jdforrester-WMF closed this task as Resolved.Jan 17 2017, 7:51 PM
Jdforrester-WMF removed a project: Patch-For-Review.