Page MenuHomePhabricator

Task description diffs sometimes don't show all changes
Closed, ResolvedPublic

Description

See T154071#2918712 . The diff shows adding

Requested licenses:

  • CC-BY

But the edit actually added

Requested licenses:

  • CC-BY
  • ODbL

...?

The last 2 lines added are not showing in the diff.

Event Timeline

Jay8g created this task.Jan 5 2017, 3:35 PM
Restricted Application added subscribers: TerraCodes, Aklapper. · View Herald TranscriptJan 5 2017, 3:35 PM
Restricted Application added a project: Upstream. · View Herald TranscriptJan 5 2017, 3:37 PM
Paladox added a subscriber: Paladox.Jan 5 2017, 3:38 PM

I'm unable to reproduce this locally when performing the exact same edit, as far as I can tell:

If anyone can figure out how to reproduce it, it's likely an easy fix.

Jay8g added a comment.Jan 6 2017, 4:08 AM

Even stranger:

It's as if that text is completely missing in the diff view...

I also can't reproduce this on this install, in the example link:

Aklapper closed this task as Resolved.May 23 2019, 11:48 AM

Cannot reproduce nowadays, https://phabricator.wikimedia.org/T154071#2918712 and https://phabricator.wikimedia.org/T154071#2920748 look as expected.

Either a heisenbug or something has changed in the meantime (server side, or maybe local browser add-ons interfering?).

Closing this task as nobody can reproduce. Please reopen if you still see this or if this happens again. Thanks!