Add Kolekcja: namespace to Polish Wikisource
Closed, ResolvedPublic

Description

The Polish Wikisource community wishes to add a new namespace pair, Kolekcja: and Dyskusja_kolekcji:

The discussion and community consensus:
Skryptorium/Pulpit_propozycji#Kolekcje

Please, set Kolekcja: namespace enabled for searching by default (wgNamespacesToBeSearchedDefault)

Z.

Zdzislaw created this task.Jan 5 2017, 10:35 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 5 2017, 10:35 PM

Just out of interest, could you explain what the purpose is of the new namespace? Might be worth documenting on Meta, so other Wikisources can consider a similar thing.

English translation is Collection and Collection talk.

Is @tomasz working on this?

What is the Collection namespace to be used for?

English translation is Collection and Collection talk.

Is @tomasz working on this?

Yes, however I usually sleep at 5 a.m. Will submit the patch as soon as I can.

I only realized you didn't claim this task yourself so that is the reason why I asked.

What is the Collection namespace to be used for?

It looks to be what enWS does with Portal: ns. (if we trust Google translate)

@Samwilson, In short, Kolekcja (collection) ns is intended to the presentation (in visual and “reader-friendly” way) of works and to group together (in a standardized way) works on similar subjects according to various criteria. See collection of works for children and teenagers, Skarbnica or SF Collection as an examples.
The idea is to help readers navigate through Wikisource and to show our works in a manner more similar to the shelves in the library, where the choice of the readers is often dictated by the image or arrangement of words on the cover. The Kolekcja ns just has become a marketing tool for improving “sales of our texts”. The addition of the new ns will facilitate the development of tools, scripts and templates which support it.

From the technical side the idea is that the “visual layer” is created automatically based on the list of links - the list is currently prepared by the users - in the future we would like to create such lists automatically by filtering the pages of selected categories, eg. by `<DynamicPageList>` tag. Currently, the problem is to use the results generated by the tags in Lua (Extension:Scribunto) – all the tags (as well as the Special pages) are converted to "strip markers" ‘UNIQ…’ and there is no way to read the strip content inside the Lua module.

Z.

@Zdzislaw do you see that tis namespace can be aligned with the namespace numbering used for Portal?. Having an approach that looks to a universal approach for the WESes would be advantageous.

Zdzislaw added a comment.EditedJan 6 2017, 11:04 PM

@Zdzislaw do you see that tis namespace can be aligned with the namespace numbering used for Portal?. Having an approach that looks to a universal approach for the WESes would be advantageous.

The idea of this namespace is different than the portal and it should not be be aligned with the namespace numbering used for Portal. Besides, in the future we are planning to use the Portal ns for the other and more general purpose.
But you're right, we should think about the unification of numbering for the WSes. So, (since in my opinion, the Kolekcja (Collection) NS has potential) we should reserve a new unique pair of numbers (120/121? 118/119?).

Z.

Ankry added a subscriber: Ankry.EditedJan 7 2017, 7:23 PM

If we wish to synchronize namespace numbering among wikis at any time, I suggest to use an unused pair, eg, 124/125. (120/121 is used as "Property" in wikidata; 118/119 as "Draft" in some wikis.)
If we do not intend to synchronize, then it does not matter: any pair is OK.

tomasz added a comment.Jan 8 2017, 8:33 PM

@Billinghurst: Any ideas as to which one we should pick? Would 124/125 be OK from your point of view?

@tomasz I was going to leave that to the experts! :-) Is there no policy about namespaces and sisterwikis? I have no issue with 124/5. Though I don't ever see that Property or Draft anss re ever going to need to be in the WSes so there is little potential of that clash. Is there value in moving to a set waaaay different?

Maybe there could be a strategic look to developing clusters of namespace per sister. Is there some value in proposing that separately? I don't know the technical reasons for the numbering patterns, and the impact of gaps, etc.

Change 331240 had a related patch set uploaded (by Odder):
Add Collection namespace to the Polish Wikisource

https://gerrit.wikimedia.org/r/331240

Scheduled for deployment at around 00:00 UTC tomorrow, 10 January (01:00 Warsaw time).

tomasz triaged this task as Normal priority.Jan 9 2017, 10:43 AM

This seems similar to the usage of the "Portal" namespace in several Wikisources, so it could use 106 (and have an alias from "Portal").

Change 331240 merged by jenkins-bot:
Add Collection namespace to the Polish Wikisource

https://gerrit.wikimedia.org/r/331240

To get a clean namespacesDupe after namespace merge, I ran this script before deployment:

Terbium
$ mwscript namespaceDupes.php plwikisource --fix
0 pages to fix, 0 were resolvable.

pagelinks from=25095 ns=0 dbk=WS:PA -> Wikiźródła:PA
pagelinks from=25100 ns=0 dbk=WS:PA -> Wikiźródła:PA
templatelinks from=341383 ns=0 dbk=Template:Custom_rule -> Szablon:Custom_rule
pagelinks from=23332 ns=0 dbk=Indeks:Słownik_języka_polskiego_(Linde) -> Indeks:Słownik_języka_polskiego_(Linde)
4 links to fix, 4 were resolvable.

Looks good!

Mentioned in SAL (#wikimedia-operations) [2017-01-10T00:58:44Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Add Collection namespace to the Polish Wikisource (T154711) (duration: 00m 41s)

tomasz closed this task as Resolved.Jan 10 2017, 1:00 AM

Dereckson has now very kindly deployed it on the cluster.

Mentioned in SAL (#wikimedia-operations) [2017-01-10T01:01:01Z] <Dereckson> Updated articles count on pl.wikisource: 491 100 (T154711)