Page MenuHomePhabricator

Workflow ID null for some user talk pages on mediawikiwiki
Closed, ResolvedPublic

Description

There are 16 of these on mediawikiwiki.

Excerpted from a dry run (P4713):

ERROR: 'User talk:Dgagan' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Kokkke' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Jkr2255' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Wikorenato33' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Ioniacob' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Awa180000' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Я эго' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Takahiro4' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Shunji tokuoka' JSON content does not have a valid workflow ID.
ERROR: 'User talk:M maheer' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Asma hichri' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Qmralzman' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Syminhky' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Albaola Faktoria' JSON content does not have a valid workflow ID.
ERROR: 'User talk:Micael rufino' JSON content does not have a valid workflow ID.
ERROR: 'User talk:AdiGrellneth190212' JSON content does not have a valid workflow ID.

All are caused by https://www.mediawiki.org/wiki/User:Translation_Notification_Bot , which is part of TranslationNotifications.

Event Timeline

They are all corrupt empty pages, with the same symptoms as T154623: Workflow ID null for some user talk pages on gomwiki, just a different extension doing the posts.

They're all also from June. The messages used to be posted similarly to NewUserMessage (directly with WikiPage). But it stopped in June because rETRN167f80029ea5: Remove publishHere changed even the local path to use cURL which blocks it with 'no-direct-editing'.

So I deleted them all manually, using the normal user-facing deletion UI, and it can't recur due to the above-linked commit. If another direct-WikiPage case occurs (regression, or another extension), it will be fixed by https://gerrit.wikimedia.org/r/#/c/330624/1 when merged.

So now I expect it is getting api.php errors and going into the 'Error editing the page' path. To actually work (post translation-related messages on Flow boards), it should use T123522: Implement a server-side mw.MessagePoster equivalent. Filed as T154736: Use server-side MessagePoster in TranslationNotifications to fix Flow.

QA recommendation: Resolve.

jmatazzoni closed this task as Resolved.Jan 17 2017, 10:40 PM