Page MenuHomePhabricator

"Register" newsletters instead of "Create"
Closed, ResolvedPublic

Description

@Peteforsyth says:

"Create a newsletter" was a stumbling block to me understanding what's envisioned. I'm trying to think of a better phrase. The problem is, I would understand "create a newsletter" to do something like offering a wizard style interface that creates a page or set of pages, preloaded with suggested formatting based on a template or transclusion...but I think what is intended is more like "adding an existing newsletter to the extension's system." If I wanted to (say) create a newsletter for an existing WikiProject, there's a lot of stuff I'd have to do that isn't included in what this extension is intended to help with.

I agree that this is a general point of confusion.

"Register" would be better than "Create", because that makes clear that the Newsletter itself must exist somewhere.

If we agree on this change, then it should be implemented in every single instanceof "creat*" in the extension.

This looks like a good task for Google-Code-in-2018 (prev proposed for Google-Code-In-2016)

Details

Related Gerrit Patches:
mediawiki/extensions/Newsletter : masterChange "Register" to "Create" in localization files (en and qqq)
mediawiki/extensions/Newsletter : masterChange alias to "Register" instead of "Create" at Newsletter.alias.php
mediawiki/extensions/Newsletter : masterRename 'create' to 'register'
mediawiki/extensions/Newsletter : masterRegister newsletters instead of create them

Event Timeline

QuimGil created this task.Jan 6 2017, 9:57 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 6 2017, 9:57 AM

This GCI task currently does not explain how to rename a string (en.json and qqq.json?).

Change 331389 had a related patch set uploaded (by Borisfba):
Rename 'create' to 'register'

https://gerrit.wikimedia.org/r/331389

@01tonythomas @Qgil
Should we also rename our specialpages from specialcreatenewsletter to specialregister newsletter? If so, that would mean a lot of the qqq.json documentation would need to be updated. I think we should do it else it would be confusing to users to see Special:CreateNewsletter and then see Register Newsletter. Let me know what you think.
Thanks!

Qgil added a comment.Jan 11 2017, 12:39 PM

It would make sense to make this change, yes.

I wonder whether we are changing anything in the backend thhat could break current installations, i.e. a rename in a database table or something. I would not touch that, and focus only in UI changes.

It would make sense to make this change, yes.
I wonder whether we are changing anything in the backend thhat could break current installations, i.e. a rename in a database table or something. I would not touch that, and focus only in UI changes.

There are no DB changes involved, but merging this would change CreateNewsletter and every instance of 'create' in the newsletter code to 'register'. This would be subtitles and navigation links and every other place it show up. Well, techincally the title=Newsletter:FooName&action=edit works though. I would just wait for your confirmation on this @Qgil and get things merged.

Qgil added a comment.EditedJan 15 2017, 3:42 PM

Yes, I think it is a good idea to eliminate the concept of "creation" from the UI, and offer the clearer concept of "registration" instead. And the right time to do this is now, before getting real adoption for this extension.

Qgil triaged this task as Normal priority.Sep 1 2017, 12:45 PM

Change 375373 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/Newsletter@master] Register newsletters instead of create them

https://gerrit.wikimedia.org/r/375373

Didn't see there was a patch up for this one already :/

Looks like it is a bit stalled, so maybe my new patch will make it through.

Addshore moved this task from Unsorted 💣 to Active 🚁 on the User-Addshore board.

@MtDu is asking some questions in the changeset that I don't have the skills to answer. @Addshore @01tonythomas your help is welcome.

Addshore moved this task from Active 🚁 to Next on the User-Addshore board.Nov 16 2017, 3:39 PM
Addshore moved this task from Next to Unsorted 💣 on the User-Addshore board.Dec 11 2017, 4:06 PM

Change 375373 abandoned by Addshore:
Register newsletters instead of create them

https://gerrit.wikimedia.org/r/375373

D3r1ck01 updated the task description. (Show Details)
D3r1ck01 added a subscriber: D3r1ck01.

Thanks @Gopavasanth, maybe you could polish up the description a little bit (if need be) and import it to the GCI site? Thanks a lot! :)

01tonythomas lowered the priority of this task from Normal to Low.Oct 28 2018, 3:08 PM
Restricted Application added a project: User-Zoranzoki21. · View Herald TranscriptDec 10 2018, 9:25 AM

Change 478620 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[mediawiki/extensions/Newsletter@master] Change strings to "Register" newsletters instead of "Create"

https://gerrit.wikimedia.org/r/478620

Change 479032 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[mediawiki/extensions/Newsletter@master] Change alias to "Register" instead of "Create" at Newsletter.alias.php

https://gerrit.wikimedia.org/r/479032

Change 479032 merged by jenkins-bot:
[mediawiki/extensions/Newsletter@master] Change alias to "Register" instead of "Create" at Newsletter.alias.php

https://gerrit.wikimedia.org/r/479032

Change 478620 merged by jenkins-bot:
[mediawiki/extensions/Newsletter@master] Change "Register" to "Create" in localization files (en and qqq)

https://gerrit.wikimedia.org/r/478620

Zoranzoki21 closed this task as Resolved.Feb 21 2019, 10:22 AM
Qgil awarded a token.Feb 21 2019, 2:08 PM