Page MenuHomePhabricator

Flow anonymous warning should be connected to the text area
Closed, ResolvedPublic

Description

When users try to post a message in flow without logging-in a message is shown to remind them they are not logged-in. The idea was to present it as part of the input area, but it currently shows a gap between both:

It should look like this instead:

I'm quite sure it used to look like the later, but some regression may have happened at some point.

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 6 2017, 10:03 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Catrope added a subscriber: Catrope.Jan 6 2017, 8:42 PM

Hmm, this is because the canNotEditWidget (for the message saying you cannot edit what you're trying to edit because you're blocked or whatever) has a height of 5px even when hidden. I'm confused as to why, because there seem to be enough line-height: 0 rules to prevent this from happening.

Change 330999 had a related patch set uploaded (by Catrope):
CanNotEditWidget: Hide properly when not active

https://gerrit.wikimedia.org/r/330999

There was related task T116573 closed, as I thought the message was not intended to be connected as that's not a pattern we follow anywhere else. And it wasn't connected any more (not done by myself!).

Change 330999 merged by jenkins-bot:
CanNotEditWidget: Hide properly when not active

https://gerrit.wikimedia.org/r/330999

Etonkovidova added a subscriber: Etonkovidova.EditedJan 25 2017, 11:06 PM

Checked in mediawiki (.wmf9)

QA recommendation: Resolve.

Volker_E closed this task as Resolved.Jan 25 2017, 11:08 PM
Volker_E removed a project: Patch-For-Review.