Page MenuHomePhabricator

No longer getting Revert notifications
Closed, ResolvedPublic

Description

On Wikidata, I no longer seem to be able to get "revert" notifications via Echo (i.e. if I make a change to an item's description, and someone reverts it, I no longer get a notification. This is for testing of our Android app that will soon allow editing of descriptions).

Event Timeline

Dbrant created this task.Jan 6 2017, 9:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 6 2017, 9:52 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 7 2017, 8:13 AM

Do you have an example of revert which didn't create a notification?

If these reverts did not trigger a notification, then it seems to be a Regression from rECHO56abaaf434938e1f5c218711f9225ffda28560e5 which fixed T153567. I think it's Wikibase that should be updated (propably inside repo/includes/Actions/SubmitEntityAction.php).

Change 331155 had a related patch set uploaded (by Matěj Suchánek):
Pass undone revision id for further proccessing

https://gerrit.wikimedia.org/r/331155

Change 331466 had a related patch set uploaded (by Thiemo Mättig (WMDE)):
This is mostly for readability of the code. Before it was not obvious that the attemptSave() method was only called for undo operations. Now this is much more obvious.

https://gerrit.wikimedia.org/r/331466

Change 331155 merged by jenkins-bot:
Pass undone revision id for further proccessing

https://gerrit.wikimedia.org/r/331155

Change 331466 merged by jenkins-bot:
Pass $undidRevId as a parameter to SubmitEntityAction::attemptSave

https://gerrit.wikimedia.org/r/331466

matej_suchanek closed this task as Resolved.Jan 20 2017, 12:29 PM
matej_suchanek claimed this task.

Tested, hopefully no future updates will break it again.