Page MenuHomePhabricator

Special pages: Allow using templates / adding interwiki links
Open, LowPublic

Description

This is a followup to T14519: Template parameters ignored during transclusion in special pages.

Using templates with parameters seems to work in many messages in many special pages now.

In some cases it fails, however, or does not work as intended. There is a template in kshwiki, the Wikipedia of Ripuarian languages, Template:Navvi_Wikkipedijas_All, which is being used so as to add interlanguage links to special pages. It is mostly inserted into the MediaWiki:*-summary messages of most special pages; but occasionally in another message, when a -summary message does not exist. (Btw., it would imho preferrable to have a separate MediaWiki:*-something-message for the template/interlanguage link stuff. Squeezing different things into one text is always a bad idea. Having to make a copy of a message text, which is local to the wiki, while the text itself does not need to be different from the standard text at all, ruling out all corrections and enhancements made to the message by developers, appears not productive to me.)

For some special pages, a way has still to be found, to incorporate interlanguage links, or make template inclusions work, or make template parameters work, respectively. Here is a list of pages in the MediaWiki name space which I have tried, and the corresponging special pages not showing interlanguage links:

  • MediaWiki:Allpages-summary
    • Special:Allpages
  • MediaWiki:Booksources-summary
    • Special:Booksources
  • MediaWiki:Sitematrix-summary
    • Special:Sitematrix
  • MediaWiki:Crossnamespacelinks-summary
    • Spezial:CrossNamespaceLinks
  • MediaWiki:Expand templates intro
  • MediaWiki:Expand templates-summary
  • MediaWiki:ExpandTemplates-summary
    • Special:ExpandTemplates
  • MediaWiki:Cite-summary
    • Special:Cite
  • MediaWiki:Logout-summary
  • MediaWiki:Logouttext
    • Special:Logout
  • MediaWiki:ParserDiffTest-summary
  • MediaWiki:Parserdifftest-summary
    • Spezial:ParserDiffTest
  • MediaWiki:Renameuser-summary
    • Spezial:Renameuser
  • MediaWiki:Deletedcontributions-summary
    • Spezial:Deletedcontributions

I have not investigated in depth, why the template generated interlanguage links do not render. Thus actual reasons may vary. Certainly interlange links are not honored in each type of message from the MediaWiki name space when used inside a special page; although they always show when you look at the respective message on its page in the MediaWiki name spage.


Version: 1.13.x
Severity: enhancement
URL: http://ksh.wikipedia.org/wiki/Template:Navvi_Wikkipedijas_All

Details

Reference
bz13489

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:03 PM
bzimport set Reference to bz13489.
bzimport added a subscriber: Unknown Object (MLST).
brion added a comment.Mar 24 2008, 8:14 PM

AFAIK interlanguage links are not available on *any* Special: page.

Can you show one where it is?

Here it is working now as intended:

http://ksh.wikipedia.org/wiki/Special:Allpages
http://ksh.wikipedia.org/wiki/Special:BrokenRedirects
http://ksh.wikipedia.org/wiki/Special:Categories
http://ksh.wikipedia.org/wiki/Special:CategoryTree
http://ksh.wikipedia.org/wiki/Special:DeadEndPages
http://ksh.wikipedia.org/wiki/Special:Disambiguations
http://ksh.wikipedia.org/wiki/Special:DoubleRedirects
http://ksh.wikipedia.org/wiki/Special:Export
http://ksh.wikipedia.org/wiki/Special:ImageList
http://ksh.wikipedia.org/wiki/Special:FilePath
http://ksh.wikipedia.org/wiki/Special:Gadgets
http://ksh.wikipedia.org/wiki/Special:NewImages
http://ksh.wikipedia.org/wiki/Special:SiteMatrix
http://ksh.wikipedia.org/wiki/Special:IpBlockList
http://ksh.wikipedia.org/wiki/Special:ListRedirects
http://ksh.wikipedia.org/wiki/Special:UserLogin
http://ksh.wikipedia.org/wiki/Special:Logs
http://ksh.wikipedia.org/wiki/Special:LongPages
http://ksh.wikipedia.org/wiki/Special:MimeSearch
http://ksh.wikipedia.org/wiki/Special:MostLinkedCategories
http://ksh.wikipedia.org/wiki/Special:MostImages
http://ksh.wikipedia.org/wiki/Special:MostLinked
http://ksh.wikipedia.org/wiki/Special:MostLinkedTemplates
http://ksh.wikipedia.org/wiki/Special:WatchList
http://ksh.wikipedia.org/wiki/Special:NewPages
http://ksh.wikipedia.org/wiki/Special:AncientPages
http://ksh.wikipedia.org/wiki/Special:LonelyPages
http://ksh.wikipedia.org/wiki/Special:FewestRevisions
http://ksh.wikipedia.org/wiki/Special:MostCategories
http://ksh.wikipedia.org/wiki/Special:MostRevisions
http://ksh.wikipedia.org/wiki/Special:WithoutInterwiki
http://ksh.wikipedia.org/wiki/Special:Preferences
http://ksh.wikipedia.org/wiki/Special:PrefixIndex
http://ksh.wikipedia.org/wiki/Special:ProtectedPages
http://ksh.wikipedia.org/wiki/Special:ProtectedTitles
http://ksh.wikipedia.org/wiki/Special:RecentChanges
http://ksh.wikipedia.org/wiki/Special:Search
http://ksh.wikipedia.org/wiki/Special:FileDuplicateSearch
http://ksh.wikipedia.org/wiki/Special:LinkSearch
http://ksh.wikipedia.org/wiki/Special:ShortPages
http://ksh.wikipedia.org/wiki/Special:Statistics
http://ksh.wikipedia.org/wiki/Special:UncategorizedCategories
http://ksh.wikipedia.org/wiki/Special:UncategorizedImages
http://ksh.wikipedia.org/wiki/Special:UncategorizedPages
http://ksh.wikipedia.org/wiki/Special:UncategorizedTemplates
http://ksh.wikipedia.org/wiki/Special:UnusedCategories
http://ksh.wikipedia.org/wiki/Special:UnusedImages
http://ksh.wikipedia.org/wiki/Special:UnusedTemplates
http://ksh.wikipedia.org/wiki/Special:UpLoad
http://ksh.wikipedia.org/wiki/Special:Contributions
http://ksh.wikipedia.org/wiki/Special:ListUsers
http://ksh.wikipedia.org/wiki/Special:Version
http://ksh.wikipedia.org/wiki/Special:WantedCategories
http://ksh.wikipedia.org/wiki/Special:WantedPages
http://ksh.wikipedia.org/wiki/Special:WhatLinksHere
http://ksh.wikipedia.org/wiki/Special:BlockUser
http://ksh.wikipedia.org/wiki/Special:DeletedContributions
http://ksh.wikipedia.org/wiki/Special:MakeBot
http://ksh.wikipedia.org/wiki/Special:Import
http://ksh.wikipedia.org/wiki/Special:MakeSysOp
http://ksh.wikipedia.org/wiki/Special:UnWatchedPages
http://ksh.wikipedia.org/wiki/Special:UserRights
http://ksh.wikipedia.org/wiki/Special:Undelete

but not here (Updated list):

http://ksh.wikipedia.org/wiki/Special:Booksources
http://ksh.wikipedia.org/wiki/Special:Cite
http://ksh.wikipedia.org/wiki/Special:CrossNamespaceLinks
http://ksh.wikipedia.org/wiki/Special:ExpandTemplates
http://ksh.wikipedia.org/wiki/Special:ParserDiffTest
http://ksh.wikipedia.org/wiki/Special:AllMessages
http://ksh.wikipedia.org/wiki/Special:BoardVote
http://ksh.wikipedia.org/wiki/Special:UserLogout
http://ksh.wikipedia.org/wiki/Special:RenameUser
http://ksh.wikipedia.org/wiki/Special:MergeAccount

There was no point in making these work:

http://ksh.wikipedia.org/wiki/Special:Random
http://ksh.wikipedia.org/wiki/Special:RandomRedirect

brion added a comment.Jan 7 2009, 6:05 PM

Bumping for bug day -- check which may still be borked.

Moving to special pages, not really i18n related.

Rather than templates this looks more like a request for all special pages to have implicit language links for every language link in the table.

(In reply to comment #5)

Rather than templates this looks more like a request for all special pages to
have implicit language links for every language link in the table.

+1

TTO closed this task as Invalid.Jan 6 2016, 12:57 PM
TTO claimed this task.
TTO added a subscriber: TTO.

I did a quick check of core, and all special page summary messages appeared to accept wikitext. Without specific, up-to-date detail of which messages need amendment, I have to close this.

He7d3r updated the task description. (Show Details)Jan 6 2016, 3:19 PM
He7d3r set Security to None.

See T15489#173358 above.

The problem was not messages not accepting wikitext. Even if they did, they did not render interwikilinks.

The problem seems fixed for many instances meanwhile but a cursory scan yielded at least a dozen candidates which likely were not.

Purodha reopened this task as Open.Jan 7 2016, 2:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 7 2016, 2:38 PM
TTO added a comment.Jan 7 2016, 2:40 PM

Fair enough, but if you would like anyone to do anything, you'll have to provide a few specific examples.

Yes, but that requires some labor which I expect to take time if done thoroughly.

I prefer the solution offered in T123063 for the final goal though, which does not require lots of local message text amendments.

TTO removed TTO as the assignee of this task.Jan 3 2017, 3:10 PM
TTO removed a subscriber: wikibugs-l-list.