Files named with cyrillic characters rejected with "The filename is too short." on Upload step
Closed, ResolvedPublic

Description

Files named with cyrillic characters are being rejected with "The filename is too short." on Upload step.

https://commons.wikimedia.org/wiki/Commons:Help_desk#Error_uploading_images_2

matmarex created this task.Jan 10 2017, 7:34 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptJan 10 2017, 7:34 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
matmarex triaged this task as "Unbreak Now!" priority.Jan 10 2017, 7:36 PM

This is very similar to T154779. We "sanitize" the cyrillic and end up with a filename like "_______.jpg", which is equivalent to ".jpg", which is a bad filename. Caused by rEUWI8a6b6a49b3fe: mw.UploadWizardUpload: Actually allow overriding AbuseFilter warnings (https://gerrit.wikimedia.org/r/#/c/327263/).

Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptJan 10 2017, 7:36 PM
matmarex edited the task description. (Show Details)Jan 10 2017, 7:37 PM

Change 331529 had a related patch set uploaded (by Bartosz Dziewoński):
mw.FormDataTransport: Don't remove Unicode characters from temp filename

https://gerrit.wikimedia.org/r/331529

Change 331529 merged by jenkins-bot:
mw.FormDataTransport: Don't remove Unicode characters from temp filename

https://gerrit.wikimedia.org/r/331529

Change 331531 had a related patch set uploaded (by Jforrester):
mw.FormDataTransport: Don't remove Unicode characters from temp filename

https://gerrit.wikimedia.org/r/331531

Change 331531 merged by jenkins-bot:
mw.FormDataTransport: Don't remove Unicode characters from temp filename

https://gerrit.wikimedia.org/r/331531

Mentioned in SAL (#wikimedia-operations) [2017-01-10T20:14:03Z] <dereckson@tin> Synchronized php-1.29.0-wmf.7/extensions/UploadWizard/resources/transports/mw.FormDataTransport.js: mw.FormDataTransport: Don't remove Unicode characters from temp filename (T155039) (duration: 00m 41s)

matmarex closed this task as "Resolved".Jan 10 2017, 8:15 PM
matmarex removed a project: Patch-For-Review.

Fixed and deployed.