Pages in the "Manual" namespace are ranked very poorly in MediaWiki.org search results
Closed, ResolvedPublic

Description

"Manual" is one of the main content namespaces on MediaWiki.org, but due to the current weighting system, if you search for anything in the Manual namespace, it often won't show up in the first page of results. For example, if you search for wgCategoryCollation, the page about this global variable (Manual:$wgCategoryCollation) is the 31st result.

There should be a way to adjust the namespace weightings per wiki and not penalize pages in the "Manual" namespace on MediaWiki.org.

kaldari created this task.Jan 11 2017, 11:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 11 2017, 11:30 PM
kaldari edited the task description. (Show Details)Jan 11 2017, 11:31 PM
kaldari added a subscriber: dcausse.

I don't think there is any way currently to configure this via the site configs.

dcausse claimed this task.Jan 17 2017, 9:05 AM
dcausse moved this task from Needs triage to Current work on the Discovery-Search board.
dcausse moved this task from Backlog to In progress on the Discovery-Search (Current work) board.

Created a replica of the mediawikiwiki index in labs to help test/tuning this wiki. I think I've setup all the wiki options properly but I can't reproduce the issue there : a search for wgCategoryCollation returns the page in the manual namespace as the first result. I must be missing some other config options, I'll continue to investigate...

Found the issue, there was a conflict with some weights set by Erik. Reset to production default and now I can reproduce. I'll start to tune the namespace weights now.

dcausse added a comment.EditedJan 17 2017, 3:12 PM

Increased weights for content namespaces from 0.2 to 0.9 and the results for wgCategoryCollation look much better now.
@kaldari could you have a quick look here? It'd be great if you have in mind a query where a low weight for such namespaces was interesting.

Side note: I'd be tempted to raise this default weight for other wikis as well, but not really sure on how to test this.

Change 332513 had a related patch set uploaded (by DCausse):
[cirrus] Increase weigths for content namespace weight on mw.org

https://gerrit.wikimedia.org/r/332513

hashar added a subscriber: hashar.Jan 24 2017, 2:03 PM

Note that we have $wgContentNamespaces which for MediaWiki.org sets: 0, 100, 102, 104, 106 (though not 12 which is Help).

Change 332513 merged by jenkins-bot:
[cirrus] Increase weigths for content namespaces on mw.org

https://gerrit.wikimedia.org/r/332513

Mentioned in SAL (#wikimedia-operations) [2017-01-24T14:13:40Z] <dcausse@tin> Synchronized wmf-config/InitialiseSettings.php: T155142 [cirrus] Increase weigths for content namespaces on mw.org (duration: 00m 39s)

I added 12 because it's part of the namespaces searched by default (set by $wgNamespacesToBeSearchedDefault).
Sadly I think we've lost the reasons why those boost were so low...
I'd love to fix this for other wikis but I'm afraid of breaking some important usecases.

kaldari closed this task as "Resolved".Jan 24 2017, 8:45 PM

Works great now. Thanks for the quick fix.