Page MenuHomePhabricator

ArticlePlaceholder stalls
Closed, ResolvedPublic

Description

While working on a GCI task I stumbled across a bug in ArticlePlaceholder where running "Translate article" stalls forever.

Steps to reproduce:

  1. Open https://eo.wikipedia.org/wiki/Special:AboutTopic?uselang=en
  2. Insert Q12345 and click craft
  3. Scroll down and click on "Krei artikolon"
  4. Click on "Translate article"
  5. Click "Ek"
  6. Wait as it stalls for an eternity

I've reproduced it in Firefox 50.1.0 and Chrome 55.0.2883.87 on Fedora 25

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 12 2017, 12:55 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptJan 12 2017, 12:57 PM

Wait as it stalls for an eternity

Hmm, cannot reproduce, page loads fine here (Firefox 51, Fedora 24).
Anything in the console of the developer tools of your web browser? (Please see Firefox ≥24; Google Chrome.)

hoo moved this task from Incoming to Backlog on the ArticlePlaceholder board.Jan 31 2017, 3:02 PM
hoo added subscribers: Lydia_Pintscher, Lucie, hoo.

Change 346167 had a related patch set uploaded (by Hoo man):
[mediawiki/extensions/ArticlePlaceholder@master] Add a name to CreateArticleDialog.

https://gerrit.wikimedia.org/r/346167

hoo claimed this task.Apr 3 2017, 3:24 PM
hoo moved this task from Backlog to Review on the ArticlePlaceholder board.
hoo moved this task from Proposed to Review on the Wikidata-Former-Sprint-Board board.

Change 346167 merged by Hoo man:
[mediawiki/extensions/ArticlePlaceholder@master] Add a name to CreateArticleDialog.

https://gerrit.wikimedia.org/r/346167

hoo closed this task as Resolved.Apr 4 2017, 4:07 PM
hoo moved this task from Review to Done on the Wikidata-Former-Sprint-Board board.
hoo moved this task from Review to Done on the ArticlePlaceholder board.
hoo removed a project: Patch-For-Review.