Page MenuHomePhabricator

Edit toolbar does not always appear on bn.wikisource due to Croptool gadget
Closed, ResolvedPublic

Description

Edit toolbar is not always appearing on Bengali Wikisource. See, the following screenshot for example

The toolbar appears very randomly upon refreshing many times.

Almost similar to T152945, except the whole toolbar is disappearing here.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 13 2017, 6:49 PM

@Bodhisattwa: Removing Wikisource tag as its says "Please do not report language specific tasks under this project (e.g. for en.wikisource)."
Also removing ProofreadPage as it's very unlikely that anything is incorrect in the code base of the ProofreadPage extension.

Bodhisattwa added a comment.EditedJan 14 2017, 5:12 AM

@Aklapper , thanks for the suggestion. The problem is gone when I deactivate the Croptool gadget.

load order? something to do with how or when resourceloader is working? Have you applied recent gadget tweaks as per the tech newsleter?

Aklapper renamed this task from Edit toolbar does not always appear on bn.wikisource to Edit toolbar does not always appear on bn.wikisource due to Croptool gadget.Jan 14 2017, 10:36 AM

Hi @Bodhisattwa, anyone can debug - you too: Open your web browser's developer tools. Reload the page on which you see the problem by adding debug=true to its URL. For example: https://bn.wikisource.org/wiki/পাতা:সভ্যতার_পাণ্ডা?action=edit&debug=true

Errors with JavaScript are printed in the 'console' of the developer tools. For more information please see:

Seb35 added a subscriber: Seb35.Jan 14 2017, 3:35 PM

Could you list what are exactly your editing preferences + gadgets, it will help to reproduce the bug. Here is a list of some parameters, which could have an influence in this bug, but add any other parameter you think it could have an influence:

  • Special:Preferences > Appearance:
    • Skin
  • Special:Preferences > Editing:
    • Enable enhanced editing toolbar
    • Enable wizards for inserting links, tables as well as the search and replace function
    • Editing mode
  • Gadgets:
    • Your enabled gadgets in the 'Editing' section + gadgets about toolbars
  • Beta features:
    • Visual editing
    • New wikitext mode

@Seb35, the problem was due to the Croptool gadget. After changing this in the Gadgets-definition, looks like the problem is gone for now.

@Bodhisattwa Good! Given you said in the description that the problem appears randomly, if you don’t experience it in the next or two next weeks (let’s say), it will be better to close the bug then (and even reopen it latter if it re-appears).

If the resolution is correct it could give a hint for T152945.

Aklapper closed this task as Resolved.Jan 17 2017, 1:56 PM
Aklapper claimed this task.