There seems to be a lot of code duplication between the three extensions. So, crazy idea: Perhaps these could be merged eventually? I'm not sure what the new name would be: WikiGames/WikiGame maybe? A new configuration could be introduced as well which could be called something like $wgWikiGamesEnable, which excepts an array.
An example where all the games are enabled:
$wgWikiGamesEnable = array( 'PollNY' => true, 'PictureGame' => true, 'QuizGame' => true, );