Page MenuHomePhabricator

CategoryTree shows dropdown when subcategory size is negative
Closed, DeclinedPublic

Description

OK so I realize that this counts as "weird edge case", so I've attached an image:

Obviously it's checking if the number of subcategories equals zero rather than >= zero. As for why I have a negative-sized category? No idea. But the page is reloadable, so it's a persistent issue with CategoryTree.

Event Timeline

labster created this task.Jan 15 2017, 7:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 15 2017, 7:41 AM
Aklapper changed the task status from Open to Stalled.Sep 17 2020, 10:37 AM

@labster: Hi, where can this be seen? Is this a public wiki that you could link to? Which MediaWiki version and CategoryTree version is this about?

Huji added a subscriber: Huji.Nov 23 2020, 9:09 PM

@Aklapper could this be another issue related to T221795 or could it not, because even if counts are incorrect, they should never be negative?

I myself do not know, sorry. :)

It is a public wiki where it could be seen three years ago for a couple months. It has since disappeared -- not sure if there was some maint script that has been run in the meantime, but there have been several MW version upgrades since then. Likely pages added to the category, too. Can no longer reproduce, sorry.

Aklapper closed this task as Declined.Mon, Jan 4, 9:48 PM

Heh, no problem. Thanks for the update. Please reopen when this happens again.