Page MenuHomePhabricator

pilimit value is higher than the max (50) in Nearby requests
Closed, ResolvedPublic

Description

The Mediawiki API action=query supports a max pilimit value of 50.

{
  "batchcomplete": "",
  "warnings": {
    "pageimages": {
      "*": "\"pilimit\" may not be over 50 (set to 100) for users."
    }
  }
}

In this situation I believe the API will simply truncate results after the fiftieth.

Event Timeline

Restricted Application added a subscriber: Aklapper. Ā· View Herald TranscriptJan 16 2017, 2:34 AM

Note this message by itself wouldn't be too much of a concern unless you're not doing continuation on your query. More concerning is T155502: Android app is hitting the action API "too-many-titles-for-query" deprecation warning because that will drop the extra values from the titles parameter.

Change 317292 had a related patch set uploaded (by Mholloway):
Retrofit NearbyFetchTask

https://gerrit.wikimedia.org/r/317292

Change 317292 merged by jenkins-bot:
Retrofit NearbyFetchTask

https://gerrit.wikimedia.org/r/317292

Dbrant closed this task as Resolved.Jan 30 2017, 4:12 PM

I may be misinterpreting your code, but it doesn't seem that this patch fixes T155502 which you closed as a duplicate of this task. It looks like PageQueryTask is more likely the culprit there, and possibly also NotificationClient.