Adjust Flow visual-edit mode interface/icons to be more consistent with visual editor
Closed, DuplicatePublic

Description

When editing a page, the interface to switch between visual editor and Wikitext works like this:

  • Click the Pencil to go to Visual Editor
  • Click the [[ ]] icon to go to Wikitext.

But in Flow discussions, the interface works like this:

  • Click the [[ ]] when it's BLUE to go to Visual Editor mode.
  • Click the [[ ]] when it's BLACK to go to Wikitext.

This inconsistency makes it difficult for users of both systems to master the switch. We should make the interfaces consistent--which probably means we should adjust Flow to be consistent with VE. (My understanding is that the VE interface came after Flow.)

Restricted Application added a subscriber: Aklapper. · View Herald Transcript
jmatazzoni removed Pginer-WMF as the assignee of this task.

I think there is room for improvement in the way to switch between rich text and wikitext, both in Flow and Visual Editor/Wikitext Editor.
There have been discussions several discussions on this. This may be a duplicate of T116417: Come up with a better re-usable UI concept for a button to switch editor-mode; the current one is confusing, and hard to discover.

jmatazzoni closed this task as Resolved.Jan 18 2017, 1:26 AM
jmatazzoni claimed this task.

Thanks Pau, you are correct. I am informed by James Forrester that there is already a plan is to fix the VE interface, which they aren't satisfied with (I agree), and then make Flow consistent with whatever they come up with. So, yes, this ticket can be closed.

and then make Flow consistent with whatever they come up with.

It would be good to do a quick check to see how that fits in the context of Flow, though. I'll take a look to the proposed solution for VE, discussed in T116417.