Page MenuHomePhabricator

Media Viewer not opening
Closed, DeclinedPublic

Description

I find the Media Viewer very helpful and time saving when viewing a number of images in succession.

But it frequently happens that Media Viewer does not open when I click on an image thumb, even though it is set to do so in the "appearences" tab of the preferences (by default on all or most Wikiprojects?) and I have never changed this setting. It happens less often in the English Wikipedia but I often notice this behaviour in the German Wikipedia as well as recently on Wikimedia Commons and the Portugese Wikipedia.

I am mostly working with Linux Mint 18 and the latest Firefox browser but this does happen on other setups as well.

Any ideas what is wrong?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 19 2017, 6:13 PM
matmarex added a subscriber: matmarex.

Can you link to specific pages where that happens?

Tgr added a subscriber: Tgr.Jan 19 2017, 11:36 PM

Probably a duplicate of T137466: MediaViewer fails to load sometimes. Can you check the value of wgMediaViewerOnClick when this happens?

It happens at random pages at random times.
For exampled selecting images from this page: https://commons.wikimedia.org/wiki/Category:Genetic_studies_on_Mestizo,
the first image opened here: https://commons.wikimedia.org/wiki/File:Average_continental_ancestry_of_Bolivians_analyzed_using_a_panel_of_46_AIMs.png
and the next image I tried opened in the Media Viewer: https://commons.wikimedia.org/wiki/Category:Genetic_studies_on_Mestizo#/media
/File:Approximate_Geographic_Location_of_the_Mestizo_and_Native_American_Populations.png,
then, going back and clicking on the first image again, it also opens in the Media Viewer: https://commons.wikimedia.org/wiki/Category:Genetic_studies_on_Mestizo#/media/File:Average_continental_ancestry_of_Bolivians_analyzed_using_a_panel_of_46_AIMs.png
Going on to to a different category right afterwards and clicking on images there, sometimes Media Viewer will appear, sometimes not.

And sorry, I could not find out how to check the value of wgMediaViewerOnClick.

best regards
Kai

Tgr added a comment.Jan 20 2017, 1:49 AM

Open the developer console (depends on browser, probably F12), type mw.config.get('wgMediaViewerOnClick').

Sorry for getting back so late.

The answer to "mw.config.get('wgMediaViewerOnClick')" is always "true".

Also the developer console delivers these error messages when opening an image without the Media Viewer:
"
ReferenceError: mw is not defined [Learn More]
This page is using the deprecated ResourceLoader module "jquery.ui.position". load.php:75:291
This page is using the deprecated ResourceLoader module "jquery.ui.widget". load.php:119:887
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead. load.php:20:84
Use of "wgUserName" is deprecated. Use mw.config instead. load.php:154:25
Use of "wgUserGroups" is deprecated. Use mw.config instead.
"
If the image opens in Media Viewer, the error messages look like this:
"
This page is using the deprecated ResourceLoader module "jquery.ui.position". load.php:75:291
This page is using the deprecated ResourceLoader module "jquery.ui.widget". load.php:119:887
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead. load.php:20:84
This page is using the deprecated ResourceLoader module "jquery.tipsy". load.php:7:171
"Deprecation warning: moment construction falls back to js Date. This is discouraged and will be removed in upcoming major release. Please refer to https://github.com/moment/moment/issues/1407 for more info." load.php:6:662
"

Also I noticed that once an image opens in Media Viewer the following images of the same category tend to open in Media Viewer as well.
When changing to a different category, Media Viewer might or might not open with the first few images I click on. After several images Media Viewer will usually open eventually.
This is the behaviour as it appears on "commons.wikimedia.org" at least.

Kai

Jdlrobson added a subscriber: Jdlrobson.

Is it possible a gadget is interfering Kai? Can you try disabling gadgets to see if the problem goes away? Should give us some clues.

Tgr added a comment.EditedJan 25 2017, 12:17 AM

Does this happen on pages with lots of images (such as categories) only? MediaViewer uses a different code path to install itself when you click on a thumbnail before the page has been fully loaded; maybe something is wrong with that.

Your last comment, Tgr, might explain this seemingly erratic behaviour.

For some reason Firefox often displays the moving circular symbol on top of the tab while the page is already fully visible.

I had noticed this before only on Wikidata, where the browser sometimes continues loading for up to ca. 15 seconds after the page has already been displayed.obviously
On Wikidata this behaviour was confusing but easy to recognize because the possibility to "visually" edit Wikipedia language entries (on the bottom left) right on the spot was only given when the page had already finished loading. Otherwise the "Set a sitelink" page opened instead (the functionality of which I never quite managed to understand).

So a quick test revealed that in fact the MediaViewer only opens when the page has finished loading.
It is quite possible that I had overlooked this in the past, i.e. this could be the whole explanation for the MediaViewer often not loading on a page I had just opened in the browser.

Maybe a statement explaining this behaviour should be placed on the relevant Wikipedia/Wikimedia pages in case other users find this puzzling as well.
I might go ahead and add a comment to the help section of the German Wikipedia.

By the way I am using Linux Mint 18 XFCE and Firefox 51.0.1 (32-bit).

best regards,
Kai

@ Jdlrobson, if by "gadgets" you mean browser add-ons, I am using these:
Lazarus
Session Manager
Downthemall!
One-click translate page
Right click translate

I will for now observe whether the page loading issue can be held responsible for MediaViewer not opening. If this does not explain it sufficently I will try browsing without those add-ons.

Kai

Tgr added a comment.Feb 1 2017, 10:13 PM

Maybe a statement explaining this behaviour should be placed on the relevant Wikipedia/Wikimedia pages in case other users find this puzzling as well.

No, this is definitely a bug. MediaViewer should catch clicks before the page is fully loaded. The relevant code is in mmv.head.js.

It's working now on Windows 10 with Firefox 50.1.0, Chrome 55.0.2883.87, Internet Explorer 11, and Edge 38.14393.0.0. I haven't checked on Linux.

It is also working on Mac OSX 10.12 with Safari 10, Chrome 56, and Firefox 51.

ovasileva triaged this task as Normal priority.Mar 9 2017, 8:30 PM

@KaiKemmann are you still experiencing this problem? Can you replicate it on other browsers / user accounts?

Aklapper changed the task status from Open to Stalled.Apr 17 2017, 10:18 AM
dr0ptp4kt moved this task from Backlog to Needs Analysis on the MediaViewer board.Apr 27 2017, 3:29 PM

@KaiKemmann are you still experiencing this problem? Can you replicate it on other browsers / user accounts?

Aklapper closed this task as Declined.Jun 23 2017, 11:28 AM
Aklapper removed KaiKemmann as the assignee of this task.

Unfortunately closing this report as no further information has been provided.

@KaiKemmann: After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!