Page MenuHomePhabricator

Zotero is not compatible with a Jessie runtime, so it needs to be removed as a dependency of role::visualeditor
Closed, ResolvedPublic0 Story Points

Description

When trying to enable role::visualeditor:

==> default: Error: /Stage[main]/Zotero/Package[xulrunner-dev]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install xulrunner-dev' returned 100: Reading package lists...
==> default: Building dependency tree...
==> default: Reading state information...
==> default: Package xulrunner-dev is not available, but is referred to by another package.
==> default: This may mean that the package is missing, has been obsoleted, or  
==> default: is only available from another source
==> default:
==> default: E: Package 'xulrunner-dev' has no installation candidate

In T107302: Package and test Zotero for Jessie it was decided not to try and backport packages to make Zotero run on Jessie. This means that we won't be able to provision and test Zotero on a Jessie-based MediaWiki-Vagrant deploy.

Event Timeline

bd808 created this task.Jan 23 2017, 6:34 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJan 23 2017, 6:34 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Mvolz closed this task as a duplicate of T107302: Package and test Zotero for Jessie.EditedJan 23 2017, 10:44 AM
Mvolz added a subscriber: Mvolz.

Unfortunately this is a known issue and it was decided that it was not possible to package Zotero for Jessie. :( See: T107302

Mvolz renamed this task from Citoid fails to provision on Jessie because of missing xulrunner-dev package to On Jessie, provision citoid without Zotero because of missing xulrunner-dev package.Jan 23 2017, 10:45 AM
Mvolz reopened this task as Open.
Mvolz lowered the priority of this task from High to Normal.

But, this is a pretty bad UX for people using vagrant on Jessie so we should have vagrant provision citoid without zotero on Jessie.

bd808 renamed this task from On Jessie, provision citoid without Zotero because of missing xulrunner-dev package to Zotero is not compatible with a Jessie runtime, so it needs to be removed as a dependency of role::visualeditor.Jan 23 2017, 5:16 PM
bd808 updated the task description. (Show Details)
Mvolz added a comment.EditedJan 23 2017, 5:35 PM

There is a config changes to go along with this too. Citoid also needs to have zotero = true to be set to zotero = false so it doesn't try to make requests to an instance that doesn't exist.

Change 333845 had a related patch set uploaded (by BryanDavis):
Remove zotero

https://gerrit.wikimedia.org/r/333845

Change 333845 merged by jenkins-bot:
Remove zotero

https://gerrit.wikimedia.org/r/333845

bd808 closed this task as Resolved.Jan 25 2017, 2:24 AM
bd808 claimed this task.
Restricted Application added a project: User-bd808. · View Herald TranscriptJan 25 2017, 2:24 AM
Jdforrester-WMF set the point value for this task to 0.Feb 2 2017, 7:00 PM