Page MenuHomePhabricator

RCFilters UI: Use mixins and variables in Less files
Closed, ResolvedPublic

Description

The current ess files use hexadecimal values for the colors in the prototype. We need to change those to Less variables, as they are repeating throughout the UI.

It would be best to use the existing color scheme, see

  • (source: https://phabricator.wikimedia.org/M82)

    It would be great if we could use the proposed built-in Less variables but they don't seem to be in core just yet (see https://github.com/wikimedia/WikimediaUI-Base)

    Instead, we should just make sure all the repeated color values are defined as Less variables and then used in the definitions.

    Details

    Related Gerrit Patches:

    Event Timeline

    Mooeypoo created this task.Jan 24 2017, 7:33 PM
    Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 24 2017, 7:33 PM
    Volker_E renamed this task from RCFilters UI: Use mixins and variables in LESS files to RCFilters UI: Use mixins and variables in Less files.Jan 25 2017, 7:11 AM
    Volker_E updated the task description. (Show Details)
    Volker_E awarded a token.
    Volker_E added a subscriber: Volker_E.

    Change 337048 had a related patch set uploaded (by Mooeypoo):
    RCFilters UI: Highlight behavior

    https://gerrit.wikimedia.org/r/337048

    Change 337048 merged by jenkins-bot:
    RCFilters UI: Highlight behavior

    https://gerrit.wikimedia.org/r/337048

    @Mooeypoo Despite the tagged patch, this isn't done yet, right?

    @Catrope so, this is half done as in we now have mixins and variables -- the ones that I was referring to are for the MW stylesheet, but I am waiting for @Volker_E to update his variables file (this one https://phabricator.wikimedia.org/source/wikimedia-ui-base/browse/master/wmui-base.less ) so we can perhaps use that.
    Otherwise, we'll have to duplicate all that data and then keep it updated when colors/variations change, which is not ideal.

    Of course, the even better ideal is if that file would be merged into core -- or could be offered as its own module -- so that we won't have to manually update it either, but we'll start with, at the very least, the upcoming standard.

    I'm moving it to "blocked".

    @Mooeypoo The most recent update of WikimediaUI Base files is captured in https://phabricator.wikimedia.org/D576 – after it get's merged, I'll push tag 0.8.0.

    SBisson removed Mooeypoo as the assignee of this task.Oct 5 2017, 1:12 PM
    SBisson added a subscriber: SBisson.

    It looks like this is ready to be worked on.

    @Mooeypoo I unassigned you so it's available for other people (Petar, for instance) but feel free to claim it back if you really want to do it.

    Change 383358 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
    [mediawiki/core@master] RCFilters: Use mixins and variables in Less files

    https://gerrit.wikimedia.org/r/383358

    Change 383358 merged by jenkins-bot:
    [mediawiki/core@master] RCFilters: Use mixins and variables in LESS files

    https://gerrit.wikimedia.org/r/383358

    Checked the highlight color functionality in testwiki (wmf.4) - no regression; works as expected.

    Etonkovidova closed this task as Resolved.Oct 17 2017, 10:39 PM