Page MenuHomePhabricator

Page Previews full feature QA
Closed, ResolvedPublic

Description

Acceptance criteria

  1. Test each case listed in the main QA document across a number of browsers and devices
  2. Take screenshots and describe unexpected behavior
  3. Note all other unexpected behavior observed (even if not part of a test case)
  4. Compile a list of test cases which were not able to be tested

Event Timeline

ovasileva removed phuedx as the assignee of this task.Jan 25 2017, 6:49 PM
ovasileva created this task.
Quiddity removed a subscriber: Quiddity.Jan 25 2017, 7:24 PM
Prtksxna removed a subscriber: Prtksxna.Jan 26 2017, 3:33 AM
phuedx renamed this task from Page previews full feature QA to Page Previews full feature QA.Jan 27 2017, 2:58 PM
phuedx updated the task description. (Show Details)Jan 27 2017, 3:45 PM

Test cases unable to be tested:

  • Number 11, non-free images

Test cases needing further reproduction

  • Number 32, Hover over β€œwith image”, preview appears, move cursor to the preview,move cursor away from preview and immediately dwell on preview before it disappears.

All other bugs logged.
Exploratory testing not yet completed

@phuedx - would we like to track automated testing separately?

No estimate, just tracked in the sprint so the team is aware of Olga and Anthony's work.

Jdlrobson moved this task from Doing to Needs QA on the Reading-Web-Sprint-92-🍜 board.
Nicholas.tsg added a subscriber: Nicholas.tsg.EditedFeb 15 2017, 10:11 PM

There's a serious issue I'm seeing and it's persisted on Chrome, Edge, Firefox even after I logged in and restored settings preferences to default - instead of a full preview window with images and preview text, I'm seeing a pop up balloon repeating the title of the article and its not bolded either. Here's a screencap of it, but according to the main QA document this is indeed unexpected behavior:

CKoerner_WMF added a comment.EditedFeb 15 2017, 10:42 PM

Hey @Nicholas.tsg it looks like you're seeing your browser's default behavior when hovering over links that have a "title" attribute set.

At the moment Page Previews are not enabled on http://reading-web-staging.wmflabs.org/wiki/Category:Popups_corpus

kaldari removed a subscriber: kaldari.Feb 21 2017, 6:37 PM

Hello, just a little update, I've been corresponding with Anthony Borba and testing the Beta Cluster sections, and letting him know of the test cases which were not able to be tested (the Staging and Production site TCs).

@ABorbaWMF - is there a chance you can take a look at IE 8 and take some screenshots? It is possible that popups might break. The fix would be related to T159164: Depend es5-shim to make popups behave on ES3 browsers, but I want to see how bad the damage is first.

phuedx added a comment.Mar 2 2017, 5:02 PM

@ABorbaWMF - is there a chance you can take a look at IE 8 and take some screenshots? It is possible that popups might break. The fix would be related to T159164: Depend es5-shim to make popups behave on ES3 browsers, but I want to see how bad the damage is first.

@ovasileva: Per the browser support matrix, we don't consider IE8 a modern browser – one that's delivered JavaScript.

Testing against the production site with Page Previews enabled as a beta feature. Page previews are not working on IE8 from my testing. I am hovering over "christmas knights"


Same results with the following combinations:
Windows 7 - IE8
Windows XP SP3 - IE8
Windows Vista - IE8

I confirmed that it works fine on the following:
Windows 7 x64 - IE9x64
Windows 7 x64 - IE9
Windows 8 - IE10

🀒

jsd;ajfa;ldskjfalsdkjabdlkajhdslfkjahs!!!!!!!!!!dlkjfhakls???!!!!!!!!!!djfhalsjdh???!!!!!!!!!!

else, it's okay they don't show up on IE8, I just wanted to make sure they don't break anything. @ABorbaWMF - for horizontal-layout previews, all looks okay?

So far I have not seen any problems with horizontal-layout.

Apologies, but I may need some clarification. The previews are not showing up on IE8 on http://reading-web-staging.wmflabs.org/wiki/Special:AllPages

According the comments, this is ok (i.e. not a bug). Is this correct? If so, it is ready for sign-off.

Thanks

Yes, we don't support JS (which powers Page Previews) on IE 8.

Yes, we don't support JS (which powers Page Previews) on IE 8.

https://www.mediawiki.org/wiki/Compatibility for the canonical source :)

I ran a test pass on the staging site and found no new issues. Tested against these systems/browsers.
Windows 10 - Chrome 56 - Edge - IE11 - Firefox 52 - Opera 43

Results: https://docs.google.com/a/wikimedia.org/spreadsheets/d/1CdHhFDoTOfbLDCuwVViAWSFlduNE88h3mCbSKIRbKcs/edit?usp=sharing
Sheet: Page preview test - Anthony

Before calling this totally complete I would like to run more tests against the beta site and a larger set of systems and browsers.

Continued testing on the Beta site.

Target pages -
https://en.wikipedia.beta.wmflabs.org/wiki/Dog
https://en.wikipedia.beta.wmflabs.org/wiki/T156800
https://en.wikipedia.beta.wmflabs.org/wiki/Star_Wars_vs_Star_Trek

Systems -
Windows 8.1 - IE11 - Chrome 56
Windows 8 - IE10 - Chrome 55
Windows Vista - IE9 - Firefox 46
Mac OSX 10.12 - Safari 10 - Firefox 52

Everything looks good. Found one, minor non-blocking issue: https://phabricator.wikimedia.org/T160237

@ABorbaWMF - I'd say let's keep this one around and track the QA for the stage 0 rollout here as well - thoughts?

Nicholas.tsg added a comment.EditedMar 22 2017, 9:38 PM

Hello, based on the initial acceptance criteria above (the main QA document steps) most of them worked on just about any OS-Browser combination but a few issues did came up that @ABorbaWMF might have mentioned before -

the Noinclude special case says "Card must NOT display text: β€œThere was invisible text above this. You should not see this text” but it does on Firefox 51.0.1, Chrome 56, IE 11 and even testing Win7-64bit-IE9 so it appears to be a consistent thing

Button X does not appear in the Page Preview Settings modal for Windows 7 (64bit) and Windows 7x64 both with IE9x64, it does finally start to appear with Windows 8 and IE10

As mentioned, before Windows IE9 Page Previews aren't supported

I do have a question for @ABorbaWMF if I need to modify the Hovercards spreadsheet to only test Windows 7x64 and later based on browsers supporting the QA being covered here. Also please keep me posted if I happened to have misunderstood this material.

P.S. I checked a few other browsers on Windows 7x64. A minimum of Google Chrome 26 and later, and Firefox 16 and later, is necessary to see the Button X. There are no issues on the Mac OSX series with Button X on Safari; it shows up even on the older Mac OSX 10.7/Safari 6 settings.

ovasileva closed this task as Resolved.Apr 13 2017, 5:07 PM