Page MenuHomePhabricator

Sync email behavior data with Civi contact records
Closed, DuplicatePublic4 Estimated Story Points

Description

There is no single place where one can find complete email performance data. Silverpop holds the sent, bounces, blocks, unsubscribes, and opens data. The pgehres on lutetium database holds clicks. Contribution tracking has the donation data.

Having some data exist in Silverpop only is bad for 3 reasons:

  1. They only hold our data for 450 days. That means all email templates, all historic opens, unsusbcribes, everything goes away after a year and a half
  2. It's really hard to so more sophisticated reporting when the data is this siloed. Trying to pull lists based on email behavior alone right now is too complicated to justify the effort (i.e. a list of people who opened the last email we sent but did not click). If I could query the data all from the same place (joins notwithstanding), so many of my reporting needs would be resolved.
  3. Donor Services and Major Gifts are missing a ton of visibility on what any single donor's experience has been, because they don't know what emails they've received.

I know @Ejegg started looking into Silverpop's API calls to integrate data about 2 years ago, and then Worldpay happened. What would it take to make this a priority this year?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 26 2017, 8:58 PM
CCogdill_WMF triaged this task as High priority.Jan 26 2017, 8:59 PM

Big +1. This would be really helpful from Donor Services' perspective. Especially the part about retaining data older than 450 days; we're cultivating long term relationships with donors and the more detail we have about their long-term experience, the better we can reach out to them.

ggellerman lowered the priority of this task from High to Medium.Jan 27 2017, 12:06 AM
ggellerman set the point value for this task to 4.
ggellerman moved this task from Triage to Q2 (Oct-Dec) 2020-2021 on the Fundraising-Backlog board.
Ejegg closed this task as a duplicate of Restricted Task.Jan 27 2017, 12:11 AM

+1. Along with de-dupe, this project would give us more of the longitudinal data that will help us understand donors' full experience with us. I think its essential information for securing future support.