Page MenuHomePhabricator

"Mark all as read" only marks currently displayed notifications as read but not "all" notifications
Closed, ResolvedPublic

Description

Problem

The Echo notifications popups have a link to mark all notifications as read but they only mark all currently-displayed notifications as read. Since the popups don't show all notifications, users with a lot of them have to "mark all as read", reload, "mark all as read" again, etc in order to actually clear their notifications.

By contrast, Special:Notifications has menu option (under the cog) that marks all notifications as read in the selected wiki.

Proposed solution

The "Mark all as read" link in the notifications popups should mark all local notifications of the popup type as read. The popup type refers to the first popup containing "alerts" and the second containing "notices".

Details

Related Gerrit Patches:
mediawiki/extensions/Echo : masterAllow marking all as read from popout window

Related Objects

Event Timeline

kaldari created this task.Jan 26 2017, 9:51 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 26 2017, 9:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@kaldari By design, 'Mark all as read' will mark as read max 25 notifications in the Notifications panel. The reason for that limitations that it's to give a user a chance to, at least, see all notificaitons before mark them as read.

If you see a different behavior or please let me know.

If I leave town for a week, I'm going to have over 100 notifications. In those cases I don't want to actually look at them all, I just want to reset my counter so I can be aware of new notifications. In the old days, all I had to do was open the notifications panel and it would reset the number. Now I have to sit there and click mark all as read over and over again. It seems confusing and frustrating that the "mark all as read" button doesn't actually mark all as read. If that's a conscious design choice, I guess I'll have to live with it, but I wanted to at least register my complaint :)

Etonkovidova added a comment.EditedJan 31 2017, 10:37 PM

@kaldari Yes, the wording 'Mark all as read' implies that all would be marked. There is a way to mark all as read - Special:Notifications page has the option to Mark all as read per wiki, e.g. - it requires refreshing the page to see that all counters reflect the action.

That may help you to manage your notifications load more easily.

Aklapper renamed this task from "Mark all as read" doesn't mark all as read to "Mark all as read" only marks currently displayed notifications as read but not "all" notifications.Sep 25 2018, 12:28 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptSep 25 2018, 12:28 PM
SBisson added a subscriber: SBisson.

I will mentor this task for Google-Code-in-2019

@SBisson can you please update this task description, something like this for inspiration ?

SBisson updated the task description. (Show Details)Nov 11 2019, 4:22 PM
IAmNetx claimed this task.Dec 3 2019, 3:50 PM

Change 554334 had a related patch set uploaded (by IAmNetx; owner: IAmNetx):
[mediawiki/extensions/Echo@master] Allow marking all as read from popout window

https://gerrit.wikimedia.org/r/554334

Change 554334 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Allow marking all as read from popout window

https://gerrit.wikimedia.org/r/554334

SBisson closed this task as Resolved.Dec 3 2019, 8:43 PM

Done in GCI