Page MenuHomePhabricator

RC - Selecting all filters in a group makes them grey out
Closed, ResolvedPublic

Description

Follow up T149435: Build user interface for the Filter Search Bar
@Pginer-WMF comment

When selecting filters from a group that result in all results being displayed, they should be shown as active in the list, since the results they represent are present in the list. This is not happening right now. If I select "registered" and "unregistered", I'd expect the filters in the list to look enabled, while the tags in the filter area to be greyed out.

The comparison below shows the current behaviour compared to the expected one (reflected in the prototype):

CurrentReference

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 26 2017, 10:44 PM
Etonkovidova renamed this task from Selecting one filter makes all other filters in the same group grey out to RC - Selecting one filter makes all other filters in the same group grey out .Jan 26 2017, 10:45 PM
Mooeypoo added a subscriber: Mooeypoo.EditedJan 26 2017, 11:55 PM

Please refer to the task T149435: Build user interface for the Filter Search Bar for details on what the issue is about.

This is about selecting the entire group -- if the entire group is selected, all items return to being active again. This should not affect selection of parts of the group of filters.

Pginer-WMF renamed this task from RC - Selecting one filter makes all other filters in the same group grey out to RC - Selecting all filters in a group makes them grey out .Jan 27 2017, 7:22 AM
Pginer-WMF updated the task description. (Show Details)

I tried to update the ticket title to better capture what to do. I think @Mooeypoo has already a clear idea, so feel free to add more details if anything else is missing.

Etonkovidova added a comment.EditedJan 27 2017, 5:20 PM

@Pginer-WMF So it seems that the previous ticket title was referring to a different bug?
Selecting one filter in a group, makes other filters in the same group to be greyed out:

When I filed that bug, I thought that the issue you were referring to is a subset of the above.

Yes, Elena, that's not a bug, that's the spec. When you select one filter out of the group, the rest are not applying to the list of results and so they're grayed out.

There's a longer explanation in the parent task that I wrote yesterday, might clarify.

This is fixed by the definition of 'fully covered' groups.

Full covered groups = all items selected will be grey
Not full coverage groups = all items are selected will not be grey

Change 339582 had a related patch set uploaded (by Mooeypoo):
Fix mute state styling

https://gerrit.wikimedia.org/r/339582

Change 339582 merged by jenkins-bot:
RCFilters UI: Fix mute state styling

https://gerrit.wikimedia.org/r/339582

Checked the fix in betalabs. The filter states indication (the greying out) differs from the prototype. Although overall, the current implementation of greying out makes sense, @Pginer-WMF please review to confirm whether some adjustments should be made.

Current - full coveragePrototype - full coverage
Current - conflictingPrototype - conflicting

Checked the fix in betalabs. The filter states indication (the greying out) differs from the prototype.

The issue described in the ticket is not fixed. When I select "Registered" and "unregistered" in the filter list, both items should be displayed with a white background in the same style they had when both were unselected. This is not happening. Currently both use a light grey instead.

Thx, @Pginer-WMF - returning to 'Ready for Pickup'.

Mooeypoo added a comment.EditedFeb 27 2017, 5:57 PM

Checked the fix in betalabs. The filter states indication (the greying out) differs from the prototype.

The issue described in the ticket is not fixed. When I select "Registered" and "unregistered" in the filter list, both items should be displayed with a white background in the same style they had when both were unselected. This is not happening. Currently both use a light grey instead.

I just want to make sure I understand fully, because this is confusing.

The reason right now both of these appear 'muted' is because selecting both is the exact same as selecting none. They also appear muted in the capsule items.

Should we change this, so the 'full coverage' meaning only appears in the capsule items, but never in the filter list?

So in this case, selecting both Registered and Unregistered -- in the filter list, they appear "normally" (white, non-muted) but in the capsule item they are both "muted" because they essentially don't affect the results.

@Pginer-WMF, is this the correct behavior?

Checked the fix in betalabs. The filter states indication (the greying out) differs from the prototype.

The issue described in the ticket is not fixed. When I select "Registered" and "unregistered" in the filter list, both items should be displayed with a white background in the same style they had when both were unselected. This is not happening. Currently both use a light grey instead.

I just want to make sure I understand fully, because this is confusing.
The reason right now both of these appear 'muted' is because selecting both is the exact same as selecting none. They also appear muted in the capsule items.
Should we change this, so the 'full coverage' meaning only appears in the capsule items, but never in the filter list?
So in this case, selecting both Registered and Unregistered -- in the filter list, they appear "normally" (white, non-muted) but in the capsule item they are both "muted" because they essentially don't affect the results.
@Pginer-WMF, is this the correct behavior?

Yes. In the list, grey rows means you won't find items of such kind in the results (because they are excluded by your filter selection). In other words, you can look at the white rows to see which properties you can expect in the results. [[ pauginer.github.io/prototypes/edit-review/highlight-changes/index.html | The prototype ]] reflects the described behaviour, you can apply different selections if you want to check more cases.

Change 340247 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
RCFilters UI: Only mute 'fullyCovered' items in the capsule

https://gerrit.wikimedia.org/r/340247

Change 340247 merged by jenkins-bot:
RCFilters UI: Only mute 'fullyCovered' items in the capsule

https://gerrit.wikimedia.org/r/340247

Etonkovidova added a comment.EditedMar 9 2017, 1:31 AM

The fix is in place - the filters that will provide 'full coverage' are greyed out in the filter selection area

If 'full coverage' filters are selected, they look as in the prototype - not greyed out.

QA recommendation: Resolve.

It sounds like the current behavior is correct. However the behavior described here is specified in par#1 of the "No-Effect Display State" spec that is part of T149391. While the part of that spec relating to the dimming of the tags is working, as per this ticket, I'm not seeing the No-Effect Display State tooltips, as described in the same place.

T156427 is a ticket I split off from T149391 that specifies how to "Implement the Conflict display states and messages" @Mooeypoo, do we need to split the No Effect tooltips off from T149391 (which is currently in QA)? Or will they be done as part of that larger task? And if I do split that off, is it just the tooltips portion that you want in that new ticket?

jmatazzoni closed this task as Resolved.Mar 9 2017, 2:27 AM