Page MenuHomePhabricator

RC filters - some filter selections cause "No active filters. All contributions are shown" to be wrongly shown
Closed, ResolvedPublic

Description

As a user, I want to see all Category changes. They can be done by registered, unregistered, and, probably, bots.

  1. Select in any order the following:

'Registered', 'Unregistered, 'Bot', and 'Category changes'.

  1. The Active Filter Display Area will display (after applying the filter selection) - 'Bot', 'Category changes' and the message: 'No active filters.All contributions are shown.'

Also, "No changes during the given period matching these criteria." is displayed (although when switched to default filters, many RC records are displayed.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 27 2017, 10:49 PM

I suppose it's quite possible that bots do not create category changes. Shoot. Is this another Conflict state?

jmatazzoni added a comment.EditedJan 27 2017, 11:13 PM

Although, I'm not sure I'd necessarily include Bot/Category as a formal Conflict state (with a specialized error message and all) unless we know that it's IMPOSSIBLE that a bot could create a category change.

(And I suppose it may be impossible, if I understand Category Changes properly. Remember that these are a derivative change. That is, they are not the actual category edit, where someone or something assigns a category to a page; these are the changes TO THE CATEGORY itself, which results from that assignment. The point being that even if a bot made the initial category assignment, the "Category change" might, I suppose, always made by, what, Mediawiki?)

"No changes during the given period matching these criteria" means there are no changes in the time period matching these filters, not none overall.

although when switched to default filters, many RC records are displayed

Please provide the link for that. By "default filters", do you mean the old UI?

I didn't see any results on Beta with an old URL (logged out, to get the old UI): https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Special:RecentChanges&hidebots=0&hidecategorization=0&hidepageedits=1&hidenewpages=1&hidelog=1&hidehumans=1

I suppose it's quite possible that bots do not create category changes. Shoot. Is this another Conflict state?

It is not a conflict state. There are some on production English Wikipedia right now, so RC_CATEGORIZE entries are definitely generated by bots:

https://en.wikipedia.org/w/index.php?title=Special:RecentChanges&hidebots=0&hidecategorization=0&hidepageedits=1&hidenewpages=1&hidelog=1&hidehumans=1

The only bug I see here is "No active filters. All contributions are shown". There are active filters.

Thanks Matt. Glad to hear this isn't a new Conflict State.

@Mattflaschen-WMF The three pieces of information displayed on the screenshot just contradicts each other - that's the point of the issue.

If we assume that 'Bot', 'Category changes' filters return 'No changes during the given period matching these criteria.' - then it contradicts to 'All contributions are shown'.
'No active filters' contradicts to the physical presence of the selected, active filters.
If we assume that 'No active filters' is true, and the filters have no effect on the results, then the default RC filters result should be shown. By default filters, I mean the new RC default filters.

Mattflaschen-WMF renamed this task from RC filters - some filter selections create misleading display in Active Filter Display Area to RC filters - some filter selections cause "No active filters. All contributions are shown" to be wrongly shown.Jan 31 2017, 2:55 AM

I can't reproduce this in master with the message "'No active filters.All contributions are shown.'"

We may have fixed this with the conflict / assessment, but I'm not sure. @Etonkovidova can you recheck?

Following your steps above, it doesn't show this message for me, but I do see results. I tried a combination of filters that doesn't show results, and I get the "No results" message below but no "all contributions are shown" error message still.

Re-checked - the issue seems to be fixed due to the filters conflict/coverage fixes. The reproducing the above steps will give the following:

QA recommendation: Resolve.

jmatazzoni closed this task as Resolved.Feb 28 2017, 9:44 PM
jmatazzoni claimed this task.