Page MenuHomePhabricator

$linkPage needs to be a string or null
Closed, DeclinedPublic

Description

My bot got several these errors today and I'm able to reproduce it via ApiSandbox (don't forget the token before submitting). The usual response looks like this (submit with token). The only place this exception can come from seems to be:

// repo/includes/ChangeOp/ChangeOpSiteLink.php
if ( !is_string( $pageName ) && $pageName !== null ) {
  throw new InvalidArgumentException( '$linkPage needs to be a string or null' );
}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 30 2017, 6:16 PM
matej_suchanek closed this task as Declined.Nov 17 2019, 9:12 AM
matej_suchanek removed a project: TestMe.