Page MenuHomePhabricator

Fatal exception of type "Scribunto_LuaInterpreterNotFoundError"
Closed, ResolvedPublic

Description

[WJRSgwpAADgAAXiYZDYAAAAR] 2017-02-03 09:51:00: Fatal exception of type "Scribunto_LuaInterpreterNotFoundError"

Event Timeline

Josve05a created this task.Feb 3 2017, 9:55 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 3 2017, 9:55 AM
Legoktm added a subscriber: Legoktm.Feb 3 2017, 9:56 AM
2017-02-03 09:51:00 [WJRSgwpAADgAAXiYZDYAAAAR] mw1261 commonswiki 1.29.0-wmf.10 exception ERROR: [WJRSgwpAADgAAXiYZDYAAAAR] /wiki/File:Possibly_Idaea_eugeniata_-_Flickr_-_gailhampshire.jpg   Scribunto_LuaInterpreterNotFoundError from line 257 of /srv/mediawiki/php-1.29.0-wmf.10/extensions/Scribunto/engines/LuaSandbox/Engine.php: The luasandbox extension is not present, this engine cannot be used. {"exception_id":"WJRSgwpAADgAAXiYZDYAAAAR","caught_by":"mwe_handler"} 
[Exception Scribunto_LuaInterpreterNotFoundError] (/srv/mediawiki/php-1.29.0-wmf.10/extensions/Scribunto/engines/LuaSandbox/Engine.php:257) The luasandbox extension is not present, this engine cannot be used.

How is LuaSandbox not installed?

Josve05a added a subscriber: Anomie.Feb 3 2017, 9:58 AM

How is LuaSandbox not installed?

@Anomie has the same question here:

This isn't a bug in Scribunto. Why is the LuaSandbox extension not being found by "extension_loaded( 'luasandbox' )" when things are using HHVM?

I reverted the new HHVM build from mw1261.

MoritzMuehlenhoff triaged this task as Medium priority.
MoritzMuehlenhoff closed this task as Resolved.Feb 7 2017, 8:45 AM

The actual root cause for this error was T157306, I'm closing this task in favour of it.