Page MenuHomePhabricator

Deploying related pages broke our browser tests
Closed, ResolvedPublic1 Story Points

Description

According to https://integration.wikimedia.org/ci/job/selenium-RelatedArticles/296/ the test ReadMore.ReadMore is not present in minerva stable no longer passes on the beta cluster.

Given we pushed this to stable of course this doesn't pass. We should update this to reflect the new state.

Event Timeline

Change 335858 had a related patch set uploaded (by Jdlrobson):
Don't run the test for minerva stable against the beta cluster

https://gerrit.wikimedia.org/r/335858

Change 335860 had a related patch set uploaded (by Jdlrobson):
Update browser test to run on desktop

https://gerrit.wikimedia.org/r/335860

Change 335860 merged by jenkins-bot:
Update browser test to run on desktop

https://gerrit.wikimedia.org/r/335860

Change 335858 merged by jenkins-bot:
Don't run the test for minerva stable against the beta cluster

https://gerrit.wikimedia.org/r/335858

Jdlrobson reopened this task as Open.Feb 6 2017, 4:24 PM

Spoke too soon...

Due to the fact that we only rolled out to 90% of users "ReadMore is not present in minerva stable" will fail sometimes if the user is bucketed in the 10% of users that don't have it :)
@pmiazga reading the code and based on the above (and the fact a new build is also green) I think your change has also applied the 90% to desktop users.. :-s

:/, could be, let me check the code

phuedx added a subscriber: phuedx.Feb 7 2017, 10:17 AM

@Jdlrobson, @pmiazga: ^ Sooooooโ€ฆ Is RelatedPages enabled for 90% of desktop users?

phuedx reassigned this task from Jdlrobson to bmansurov.Feb 7 2017, 12:24 PM

90% of beta feature users ;)

There's now no reason our browser tests should be passing for this reason anymore so this should be fixed but I can't verify as there's a new kid in town who's making all our browser tests red. See T123557.

I still see the original tests not passing: https://integration.wikimedia.org/ci/job/selenium-RelatedArticles/308/#showFailuresLink

Also, according to a comment at T123557, that problem is not related to these failures.

bmansurov removed bmansurov as the assignee of this task.Feb 9 2017, 9:03 PM
bmansurov added a subscriber: bmansurov.

I opened T157711. The error is the same but not the cause.

T157665 is a different problem to the one in this ticket that is impacting ALL browser tests so this is back to sign off. We can verify this is fixed when T157665 is fixed.

Jdlrobson closed this task as Resolved.Feb 10 2017, 6:15 PM
Jdlrobson claimed this task.

Issue is now fixed (see T157636) and has passed for the last 3 builds. Hurrah.