Page MenuHomePhabricator

Autowikibrowser diff text box's direction for RTL languages should be RTL
Closed, ResolvedPublic

Description

Diff text box for RTL languages should be RTL.

Event Timeline

Yamaha5 created this task.Feb 5 2017, 9:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 5 2017, 9:33 PM
Yamaha5 moved this task from Backlog to Interface on the AutoWikiBrowser board.Feb 5 2017, 9:36 PM
Huji added a subscriber: Huji.Feb 6 2017, 2:42 AM

Even better, the DIFF should be in the same direction as that on Wiki (as in, JS pages always RTL, content pages based on the content, ...)

alireza added a subscriber: alireza.Aug 6 2017, 7:47 AM
Amire80 moved this task from Untriaged to RTL on the I18n board.Feb 26 2018, 10:39 AM

I think this can be done by user CSS. If that's confirmed we can add to the default AWB CSS to apply for RTL wikis.

See https://en.wikipedia.org/wiki/Wikipedia:AutoWikiBrowser/style.css Create your style.css file, after the first

background-color: white;

add a further line with

direction: rtl;

that should do what you're looking for.

Amire80 added a subscriber: Amire80.Oct 5 2018, 8:27 PM

Ah, thank you. This is a good pointer.

I played with it, and it looks like a better thing to do is to add it to this section:

td.diff-addedline,
td.diff-deletedline,
td.diff-context {
	direction: rtl;

Applying it to the whole table also flips the order of the columns, which is not what we need. (I suspect that core MediaWiki is to blame for this, but I'm not in the mood for digging into this...)

So yeah, if you add this line for RTL wikis it will probably be a good fix for everybody.

Rjwilmsi closed this task as Resolved.Oct 6 2018, 9:50 AM
Rjwilmsi claimed this task.

rev 12316 in default CSS set

direction: rtl;

on RTL wikis to align diff text correctly