Page MenuHomePhabricator

phpunit 4.8 no longer supported
Closed, DuplicatePublic

Description

From https://phpunit.de/

PHPUnit 4.8 is no longer supported.
It became stable on August 7, 2015.
Its support ended on February 3, 2017.

You can find out what was new in PHPUnit 4.8 in the release announcement.

PHPUnit 4.8 was supported on PHP 5.3, PHP 5.4, PHP 5.5, and PHP 5.6.

MW core has

"phpunit/phpunit": "4.8.31",

4.8.34 seems to be the last available version... Probably worth updating in core and in CI stuff

I know we're still using 4.8 as we need PHP 5.3 support... Roll on May 2017 when we don't need to support REL1_23 :), and can use the new old stable of 5.7 ;)

Event Timeline

Reedy created this task.Feb 5 2017, 11:17 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 5 2017, 11:17 PM
Reedy triaged this task as Low priority.Feb 5 2017, 11:17 PM
Paladox added a subscriber: Paladox.EditedFeb 5 2017, 11:35 PM

@Reedy phpunit 5.7 requires php 5.6, but we will need to support php 5.5 as 1.27 supports php 5.5.

Also we need 4.8 to support php 5.5. We could have migrated to 5.7 but they support php 5.6+ not php 5.5+

Krinkle moved this task from Inbox to PHPUnit on the MediaWiki-Core-Testing board.Jul 7 2017, 5:03 AM