Page MenuHomePhabricator

Plain text paste into new wikitext editor adds newline markers wrongly
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  • go to P4905
  • click on "view raw file"
  • select all & copy to clipboard
  • paste it into edit window (with ctrl-v)

All the text will appear on a single line, with newline characters displayed as (I think) U+21B5 . They are proper enter newline characters though, can be copy-pasted into other applications.

I have seen similar behavior with tab characters recently (displayed as a right arrow character).

Tested with Chrome 55 / Ubuntu 16.04.

Event Timeline

Tgr created this task.Feb 7 2017, 9:06 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptFeb 7 2017, 9:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Tgr updated the task description. (Show Details)Feb 7 2017, 9:26 PM

Looks like this is mostly fixed in master, except that all the content after '''comments:'''<br> has newline markers.

the breakage at the end is being cause by a faulty loop (not incrementing length as the array grows)

Change 336694 had a related patch set uploaded (by Esanders):
SourceMode: Fix sanitization loop in plain text paste

https://gerrit.wikimedia.org/r/336694

Jdforrester-WMF renamed this task from New wikitext editor displays some control characters (enter, tab) as icons, making text hard to read to Plain text paste into new wikitext editor adds newline markers wrongly.Feb 8 2017, 11:14 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

(Re-titled as the bigger bit is fixed in another ticket.)

Change 336694 merged by jenkins-bot:
SourceMode: Fix sanitization loop in plain text paste

https://gerrit.wikimedia.org/r/336694

Change 336899 had a related patch set uploaded (by Jforrester):
Update VE core submodule to master (0dfc50a88)

https://gerrit.wikimedia.org/r/336899

Change 336899 merged by jenkins-bot:
Update VE core submodule to master (de7a96ece)

https://gerrit.wikimedia.org/r/336899

Jdforrester-WMF closed this task as Resolved.Feb 10 2017, 12:18 AM
Jdforrester-WMF removed a project: Patch-For-Review.