Page MenuHomePhabricator

more "jump to" accessibility links needed
Closed, DeclinedPublic

Description

Please consider e.g.,
http://en.wikipedia.org/wiki/Sex-positive_feminism

Please view it with w3m or lynx, (or Firefox without the stylesheets.)

You see this line: "Jump to: navigation, search".

Please make sure you see that line before you proceed reading this
bug. If not you are not using the right (text) browsing environment,
or are logged in without this preference.

OK. Now the problem is: "Jump to: navigation, search" is not enough.

For instance, the TOC is also a "hot" destination, hard to get to
through all the verbiage. Therefore, the line should read
"Jump to: TOC, navigation, search".

But wait, for such articles with lots up front template-wise,
"section 0" would also be a good destination for a short cut. So
"Jump to: Sec 0, TOC, navigation, search".

Should all four items always be present, or be present depending on
distance needed to reach them on a particular page?

Probably they should always be present, so they don't slip around from
page to page, making the user have to look closely before clicking.

(Perhaps now section 0 is called Lead section... or maybe call the link "content".)


Version: 1.21.x
Severity: enhancement
URL: http://en.wikipedia.org/wiki/Sex-positive_feminism

Details

Reference
bz13765

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 10:08 PM
bzimport set Reference to bz13765.
bzimport added a subscriber: Unknown Object (MLST).
Jidanni created this task.Apr 16 2008, 3:32 PM

And by the way, say one has pleasantly browsed one's way all the way
down to the References,
http://en.wikipedia.org/wiki/Sex-positive_feminism#References
and one wishes to skip the certain screen after screen of references
(well, actually not that many for this particular article) and see
what lies beyond them.

So maybe
[edit] References
should be
[edit] [skip] References
Where [skip]'s href="#name of next section".

OK, let this particular sub bug wait for: better browser features, or
the Reference Team's newer templates, instead of messing up MediaWiki
to implement it.

LATER per comment 1

GregUbben wrote:

This feature as implemented is mostly useless anyway. New users (including screen reader users) will never see it since the default skin hides it via display:none. And regular users will have found the other shortcuts to reach these sections of the page.

  1. Text browsers are not thrown off track by "display:none".
  1. The current version has now absconded with any jump downward link

at all!

  1. Therefore the only way for text browser users to get anywhere other

than the items offered in the Table of Contents, if any, is to "go
search for it with your browser's 'search string' function". Of course
one needs previous knowledge of what one is searching for.

Else one must just scroll through the whole article.

What I'm saying is for fancy browser users, all the Edit, History, Preferences, Contributions links are right there at the top of the page.

But for text browser users, its "Go dig for them, Holmes."

OK the "Jump to" link is back...

No, the Jump to link is not back.

Still valid in 1.21wmf6.
[Removing RESOLVED LATER as discussed in http://lists.wikimedia.org/pipermail/wikitech-l/2012-November/064240.html . Reopening and setting priority to "Lowest". For future reference, please use either RESOLVED WONTFIX (for issues that will not be fixed), or simply set lowest priority. Thanks a lot!]

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 5 2015, 6:12 AM
tstarling added a subscriber: tstarling.

The relevant WCAG 2.0 success criterion is SC 2.4.1 Bypass Blocks: "A mechanism is available to bypass blocks of content that are repeated on multiple Web pages. (Level A) "

MediaWiki by itself probably does well enough to pass this, but if editors add cleanup templates and the like to the content area, then the resulting content would fail this criterion. MediaWiki should probably provide editors the ability to add a "lead" link to the jump list.

Jidanni requested a TOC link, although the existing <h2>Contents</h2> is apparently good enough for WCAG purposes. Similarly for skipping references.

Volker_E closed this task as Declined.May 15 2019, 5:17 PM

Agreeing with @tstarling here. Screen reader navigation through semantic headings seems acceptable for AT users.

Side-note: “Jump to TOC” would also be a bad choice, as acronyms (even those marked-up semantically and attributed with an explanatory title) are not recommended for link descriptions.

Jidanni added a comment.EditedMay 15 2019, 11:22 PM

By the way, using

$ w3m -dump http://en.wikipedia.org/wiki/Sex-positive_feminism

There are these weird "[ ]"'s

Namespaces

  • Article
  • Talk

[ ]

Variants

Views

  • Read
  • Edit
  • View history

[ ]

@Jidanni: Please file separate task for separate issues unrelated to this task.
Furthermore, it seems w3m ignores style="display:none" CSS which I don't consider something to fix or change in MediaWiki.