Page MenuHomePhabricator

Exception thrown with an uncommited database transaction: MWCallableUpdate::doUpdate: Flush failed on server(s)
Closed, ResolvedPublic

Description

2017-02-09 13:14:20 translatewiki.net translatewiki_net-bw_: Exception thrown with an uncommited database transaction: [e825b3b1f84ed390adc0c586] /wiki/Special:ImportTranslations DBExpectedError from line 1136 of /srv/mediawiki/tags/2017-02-09_08:44:01/includes/libs/rdbms/loadbalancer/LoadBalancer.php: MWCallableUpdate::doUpdate: Flush failed on server(s) 127.0.0.1:3306:

Probably triggered by users importing new translations since T151585 was fixed. We don't know of any loss of data (i.e. any translations which failed to be imported from the PO file).

Event Timeline

Nemo_bis created this task.Feb 9 2017, 1:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 9 2017, 1:18 PM
mwjames added a subscriber: mwjames.Feb 9 2017, 2:05 PM

Maybe those are related T154438 and T154425 (was reported a month ago) but without any comment or activity on them, it is unclear whether they share a common root cause or not.

Seb35 added a subscriber: Seb35.May 30 2017, 8:27 AM

Change 356619 had a related patch set uploaded (by Seb35; owner: Seb35):
[mediawiki/core@master] Use AtomicSectionUpdate instead of Database->onTransactionIdle

https://gerrit.wikimedia.org/r/356619

Seb35 claimed this task.Jun 1 2017, 4:39 PM

Change 356619 merged by jenkins-bot:
[mediawiki/core@master] Use AutoCommitUpdate instead of Database->onTransactionIdle

https://gerrit.wikimedia.org/r/356619

Change 357560 had a related patch set uploaded (by Seb35; owner: Seb35):
[mediawiki/core@REL1_29] Use AutoCommitUpdate instead of Database->onTransactionIdle

https://gerrit.wikimedia.org/r/357560

Change 357561 had a related patch set uploaded (by Seb35; owner: Seb35):
[mediawiki/core@REL1_28] Use AutoCommitUpdate instead of Database->onTransactionIdle

https://gerrit.wikimedia.org/r/357561

Change 357561 merged by jenkins-bot:
[mediawiki/core@REL1_28] Use AutoCommitUpdate instead of Database->onTransactionIdle

https://gerrit.wikimedia.org/r/357561

Change 357560 merged by jenkins-bot:
[mediawiki/core@REL1_29] Use AutoCommitUpdate instead of Database->onTransactionIdle

https://gerrit.wikimedia.org/r/357560

Seb35 closed this task as Resolved.Jun 9 2017, 7:34 AM

Closed this task given it is almost a duplicate for T154425, it is solved by https://gerrit.wikimedia.org/r/#/c/356619/ (fixed in 1.28, 1.29, 1.30). An issue remains as of now, see T154425 for details.