Page MenuHomePhabricator

"Attracted Developers" widget in "Demographics" panel unexpectedly lists "old" developers
Closed, ResolvedPublic

Description

(Jesus and I found this bug last weekend; logging here so I don't forget.)

STEPS TO REPRODUCE:

  1. Go to https://wikimedia.biterg.io/app/kibana#/dashboard/Git-Demographics
  2. Click "Last 2 years" in upper corner
  3. Click "Relative", choose "From: 20 years ago; To: Now", click "Go"
  4. In the "Attracted Developers" widget, click the last month (January 2017; "Attracted Developers: 23").
  5. ("author_min_date: "Jan 1st 2017 to Jan 31st 2017"" filter is added.)
  6. In the "Last Attracted Developers" widget, click the list item "Bartosz Dziewonski (matmarex)".
  7. ("author_name: "Bartosz Dziewonski (matmarex)"" filter is added.)
  8. Un-apply the first of the two filters (author_min_date) to see all of Bartosz' contributions.

EXPECTED OUTCOME:
As Bartosz was listed as one of the "last attracted developers" I'd expect that there are no "older" contributions by Bartosz.

ACTUAL OUTCOME:
"Attracted Developers" widget shows that Bartosz was active in Sep 2012, Aug 2013, Sep 2014, and Jan 2017:

Event Timeline

Aklapper created this task.Feb 9 2017, 3:01 PM

I had an (incorrect) suspicion that developers count as "attracted" (new) when they use a different email address that they had not used before.
Regarding the specific example above, in git commit 73b7a9c84c297f4807b792c29851c3f1ffada139 on 2017-01-27 I merged
"id": "6ffe28ca23acc58706f423d9bf4faf261138440e" which has "source": "wikimedia:scm" into
"id": "01902f9037493fa08ba374e5cf063e1e92398a9a".
However the latter id already included that email address for "source": "wikimedia:scm", so that's not an explanation...

Aklapper closed this task as Resolved.Mar 23 2017, 12:01 PM
Aklapper claimed this task.

Cannot reproduce anymore since T157898#3124564 (yay!) hence closing.

Potentially related followup issues to be handled in different places (like T161211).