Page MenuHomePhabricator

On the "Git" dashboard, filtering on one organization still lists authors who are with another organization
Closed, ResolvedPublic

Description

STEPS:

EXPECTED OUTCOME:

  1. Person who is not enrolled with "Independent" should not be listed under "Independent".

ACTUAL OUTCOME:

  1. It's unclear why this user is listed on the dashboard when "Organizations == Independent" is selected.

Event Timeline

Aklapper created this task.Feb 9 2017, 6:07 PM

The original testcase above is not valid anymore after T157898#3124564, but other ones are. I will update the task description accordingly.

Aklapper updated the task description. (Show Details)Mar 23 2017, 12:16 PM

According to Bitergia, T157898 and T161235 (and to some extent T157709 though half of that is T161308) are side effects of an older version as the DB is not synced in an automatic way. This should get fixed within the next 2-3 weeks.

Qgil added a subscriber: Qgil.Apr 19 2017, 3:17 PM

This task committed to Developer-Advocacy (Apr-Jun 2017) needs an owner.

Qgil assigned this task to Albertinisg.Apr 27 2017, 8:16 PM
Qgil moved this task from Backlog to Ready to Go on the Developer-Advocacy (Apr-Jun 2017) board.

@Aklapper , after the changes made in the DB the issue is gone, and those users are not listed as Independent anymore. Note that the user ^demon is now Chad Horohoe (as we also modified the preferences for the profile name). Please, close it if you consider it fixed!

@Aklapper , after the changes made in the DB the issue is gone, and those users are not listed as Independent anymore.

@Albertinisg: It looks way better, thanks!
One question though: Going to https://wikimedia.biterg.io/goto/e402bc401b1c41a37031d903bd0c424a ("Independent" org filter applied), in the "Authors" list widget, I see Nikerabbit listed. Looking at 2eec48ebcf2b23fc60a95c080a3190b4a75a6568 in the DB dump file (I know it's not in sync but I'm pretty sure there have not been changes to that entry lately) that item has "organization": "Wikimedia Foundation". So I would not expect that single entry to be displayed?

But that's currently the only item that surprises me. Everything else, like people who worked as volunteers and then for the WMF, are shown as expected (example). Yay!

(as we also modified the preferences for the profile name)

I like that! (I wonder if that also made sortinghat assign new uuids to all items I'm importing from wikimedia-identities.json into my SQL DB locally...) :)

That's true, I see this identity is not properly merged in the db:

unique identity 1571e940a2fba27a0633b78ea182c3271b0026b7

Profile:
    * Name: Nikerabbit
    * E-Mail: niklas.laxstrom@gmail.com
    * Bot: No
    * Country: US - United States of America

Identities:
  011fba17981957411db788211d2e314804a7da95	Niklas Laxström	niklas.laxstrom@gmail.com	-	git
  1571e940a2fba27a0633b78ea182c3271b0026b7	-	-	Nikerabbit	wikimedia:mediawiki
  49bdd70d3884a3143a664c885fa4ea6e944ff7db	nikerabbit	nikerabbit@dd0e9695-b195-4be7-bd10-2dea1a65a6b6	-	wikimedia:scm
  5333837e04d005fca5a43d4b7c6d713e1518f23d	Nikerabbit	niklas.laxstrom@gmail.com	nikerabbit	wikimedia:scr
  562fe6c738893ee3ab82ae7168698c53591373a5	 Niklas Laxström 	niklas.laxstrom@gmail.com	-	pipermail
  70d91b038645e85c0f524210570bf6c9c7fd0204	Nikerabbit	niklas.laxstrom@gmail.com	nikerabbit	gerrit
  83f413385e191d052abe2f536f957673298cbc50	None	niklas.laxstrom	niklas.laxstrom	wikimedia:its
  88fa07cd3edf70e50a0be52c03995526c77dea3d	Nikerabbit	niklas.laxstrom@gmail.com	-	wikimedia:scm
  8b343de28530722e8e775d6e62aea0cab0fe11fb	=?ISO-8859-1?Q?Niklas_Laxstr=F6m?=	niklas.laxstrom@gmail.com	niklas.laxstrom	wikimedia:mls
  b6d2a8db6011335897833509dc4539c1b63d85ba	Niklas Laxström	None	Nikerabbit	wikimedia:its_1
  cb32068b3aaee2c6b899b287234ad1f0b4bd5a97	Niklas Laxström	nikerabbit@users.mediawiki.org	-	git
  d944b246f6df2334cd9db358b5f4feb9af72b36e	Niklas Laxström	nikerabbit@users.mediawiki.org	-	wikimedia:scm
  dd58451ad23fb5c856835bbcaa9dd8612bbd6fde	-	-	niklas.laxstrom@gmail.com	wikimedia:its
  e98812ddfcd2c13d83a400ededdc3b0c6572993d	Nikerabbit	niklas.laxstrom@gmail.com	-	git
  eee77cb6c58321f16d58c4f3be61ad1b0409e15d	-	-	Nikerabbit	wikimedia:irc
  f29757cdcf38ff6a4f5818e43de8ce452d7bacae	Niklas Laxström	niklas.laxstrom@gmail.com	-	wikimedia:scm
  f4bc7f23c06ce0c87ec010f80b6ea6672723dbe8	Niklas Laxström	niklas.laxstrom@gmail.com	niklas.laxstrom@gmail.com	wikimedia:its
  fca230033d417287966e30fbbd1adb7e2017d7b1	Niklas Laxström	-	Nikerabbit	phabricator

Enrollments:
  Wikimedia Foundation	1900-01-01 00:00:00	2015-01-01 00:00:00

unique identity 2f47b2b7819ce92ae7cfd9d3133a0f2d0ddf1733

Profile:
    * Name: nikerabbit
    * E-Mail: nikerabbit@dd0e9695-b195-4be7-bd10-2dea1a65a6b6
    * Bot: No
    * Country: -

Identities:
  2f47b2b7819ce92ae7cfd9d3133a0f2d0ddf1733	nikerabbit	nikerabbit@dd0e9695-b195-4be7-bd10-2dea1a65a6b6	-	git

No enrollments

This is something I would like to check carefully, because the identity should have been merged automatically with the email nikerabbit@dd0e9695-b195-4be7-bd10-2dea1a65a6b6.

Albertinisg added a comment.EditedMay 9 2017, 5:09 PM

Hey @Aklapper, I've been digging into this and I found what's going on with this user. There are some e-mail address our tool don't merge automatically. In this case, the matching wasn't done due to the e-mail format. The tool avoids some kind of addresses like the ones who end in localhost or like this one.

I will merge it manually, and then update the index. Still, if you find any other case like this, let me know! I will update the ticket as soon as the index is updated :)

I like that! (I wonder if that also made sortinghat assign new uuids to all items I'm importing from wikimedia-identities.json into my SQL DB locally...) :)

The uuid should remain the same. To generate it, we use four fields: name, email, username and source. As the change applies to the name displayed in the profile, the uuid won't change.

Aklapper closed this task as Resolved.May 16 2017, 12:50 AM

Thanks a lot! All looks correct now, hence closing as resolved.

Qgil awarded a token.May 18 2017, 12:52 PM