Page MenuHomePhabricator

Use doQuickOperations instead of foreach loops calling quickStore/quickStore
Closed, ResolvedPublic

Description

cf T157736#3014843

[21:27:26] <Reedy> AaronSchulz: is there a way with filebackend stuff to store many files in one go?
[21:27:33] <Reedy> rather than a for loop calling quickStore?
[21:29:57] <AaronSchulz> like doQuickOperations?
	 * Perform a set of independent file operations on some files.


	 * b) Copy a file system file into storage
	 * @code
	 *     [
	 *         'op'                  => 'store',
	 *         'src'                 => <file system path, FSFile, or TempFSFile>,
	 *         'dst'                 => <storage path>,
	 *         'headers'             => <HTTP header name/value map> # since 1.21
	 *     ]
	 * @endcode

Details

Related Gerrit Patches:
mediawiki/extensions/ConfirmEdit : masterSwitch file store/delete operations to batch operations

Event Timeline

Reedy added a comment.Feb 16 2017, 9:06 PM

There's the deletes to do too..

Change 338169 had a related patch set uploaded (by Reedy):
Switch file store/delete operations to batch operations

https://gerrit.wikimedia.org/r/338169

Change 338169 merged by jenkins-bot:
Switch file store/delete operations to batch operations

https://gerrit.wikimedia.org/r/338169

Reedy closed this task as Resolved.Jun 12 2017, 3:59 PM

Yup, I think so