Page MenuHomePhabricator

Investigate why archivebot.py selectively fails on eu.wikibooks
Closed, ResolvedPublic

Description

pwb.py archivebot User:MABot/config -family:wikibooks -lang:eu
Fetching template transclusions...
Processing [[eu:Wikibooks:Txokoa]]
61 Threads found on [[eu:Wikibooks:Txokoa]]
Looking for: {{Lankide:MABot/config}} in [[eu:Wikibooks:Txokoa]]
Processing 61 threads
Only 0 (< 1) threads are old enough. Skipping

While there are some old threads without proper signatures, others in the bottom does have signatures and yet the bot ignores them because they're not too old.

Settings are:

{{Lankide:MABot/config
|algo = old(30d)
|archive = Wikibooks:Txokoa/Artxiboa/%(year)d
|archiveheader = 
|minthreadsleft = 2
|minthreadstoarchive = 1
}}

Previous run archived some, then it failed all the times, even with the "-force" option.

Event Timeline

The problem is that the format of timestamps has changed over time.
Archivebot recognises only the last valid convention, so the last two threads will be archived, when it will be the right time.

I tried a workaround, at least for english dates, but t did not work as I expected, you will see some 'Undo' in the example you posted.

I created a current timestamp to see the current format and added to each thread a reply with that new timestamp modified with the date that thread was posted and the bot did worked this time. The only change I noticed so far between old and new timestapms are that the month names were formerly capitalized while now they are not. Maybe this should be made case-unsensitive to avoid failures for petty things like this. IDK. Closed as resolved for now. Thanks for your help @Mpaa.