Page MenuHomePhabricator

The Filter Search Bar - adjustments to RC page layout
Closed, ResolvedPublic

Description

As a follow up to @Pginer-WMF notes:

(1) Keyboard selection should be possible. Currently when typing "Registered" and hitting enter, nothing happens. I'd expect to have the top element highlighted by default when typing and being able to move up and down with cursors.

(2) Focusing the search bar should make the page progressively scroll to mode the filter area to the top of the page, leaving more room for filters.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 13 2017, 11:10 PM

#2 is fixed in master. #1 isn't, and is blocked on me redoing my menu-not-popup patch.

#2 does not seem to work well in beta:

  • If you are at the very top of the page it scrolls down. The current behaviour is ok, but it would be better if the whole active filter area were visible after scrolling (currently part of the top area is out of the viewport).
  • If you are not at the very top of the page, focusing on the search bar will move you down for no reason making the search bar move out of the viewport. This is problematic. The intended behaviour is to either scroll until the filter area is on top, or do nothing if the viewport is too close or below that point.

I made a recording showing the issue.

You can check the intended behaviour on how to react to different viewport positions in the prototype.

Change 341388 had a related patch set uploaded (by wikigit):
[mediawiki/core] RCFilters UI: Fix scrolling behavior on search/popup

https://gerrit.wikimedia.org/r/341388

Change 341388 merged by jenkins-bot:
[mediawiki/core] RCFilters UI: Fix scrolling behavior on search/popup

https://gerrit.wikimedia.org/r/341388

Mooeypoo claimed this task.Mar 6 2017, 11:09 PM
Mooeypoo added a subscriber: Mooeypoo.

#2 is done. #1 still awaits the switch to a menu widget.

Verified

  • #1 is done except "being able to move up and down with cursors" between selected options.
  • #2 is done.

QA recommendation: Product should weigh in.

jmatazzoni closed this task as Resolved.Mar 9 2017, 1:04 AM
jmatazzoni added a subscriber: jmatazzoni.

I think we can live without being able to use cursors in the menu. Resolving this. @Pginer-WMF, if I've missed the importance of this feature please speak up.

I think we can live without being able to use cursors in the menu. Resolving this. @Pginer-WMF, if I've missed the importance of this feature please speak up.

I think it is ok to skip it for the initial launch, but I think it would be good to keep a (low-priority) ticket for it to keep the idea in case we, a volunteer, or the people in charge of the general UI components decides to support this in the future..