Page MenuHomePhabricator

Inserting whitespace shows up in a diff, but deleting whitespace is collapsed and not shown
Closed, ResolvedPublic

Description

Author: rememberthedot

Description:
Compare:

http://en.wikipedia.org/w/index.php?title=Wikipedia:Sandbox&diff=prev&oldid=206801526
http://en.wikipedia.org/w/index.php?title=Wikipedia:Sandbox&diff=next&oldid=206801526

These should be symmetrical, but they are not. When deleting whitespace, the software collapses it and does not show it as a change.

You may need to add

.diffchange-inline {

border: none;
border-bottom: 1px solid #f00;

}

to your CSS to see the difference properly.


Version: unspecified
Severity: enhancement

Details

Reference
bz13804

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:09 PM
bzimport set Reference to bz13804.
bzimport added a subscriber: Unknown Object (MLST).

ayg wrote:

CC'ing Nikerabbit, who added the class.

I have no idea what has happened, there is no such class in example urls anymore.

Aklapper closed this task as Resolved.Sat, Aug 10, 9:26 PM
Aklapper added a subscriber: Aklapper.

Cannot reproduce anything unexpected with the two links provided, using Vector skin. Probably fixed by https://www.mediawiki.org/wiki/MediaWiki_1.20#Diff ?

Please reopen this task if this still happens and provide a screenshot.