The current i18n conventions for message keys are that they need to be:
- entirely lowercased along with
- hyphens between words in the name of the key
- and finally, the extension (or at least module) as the prefix for the keys. Currently all of them are lowercase, but some aren't hyphened correctly (e.g boardlinkselectall or userboard_owner) or aren't prefixed correctly (the former one I mentioned fits this example, but there's other examples too such as boardsendbutton). These should be renamed (along with the references to the message keys) to fit conventions.