Page MenuHomePhabricator

Requesting shell access and access to groups 'analytics-privatedata-users' and 'researchers' for Shreyas Lakhtakia (shrlak)
Closed, ResolvedPublic

Description

original request

Hi,

Fundraising has hired CPS Data Consulting, whom I work with, to help with fundraising analytics. According to @Ottomata the appropriate access groups are 'analytics-privatedata-users' and 'researchers'. Accordingly, I would like to request shell access as well as access to 'analytics-privatedata-users' and 'researchers' to work with fundraising's banner history data.

Thank you for helping with this!

Username: shrlak
Full name: Shreyas Lakhtakia

Wikitech username: shrlak
Shell account name: shrlak

My public key, for RSA authentication, is as follows:

ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQD2rhvzjTJt5Ac349bzg1JI3QIKsulc3Fl9PqeuIsLeudgNOY9yUa4aByj03ajLdF25ctlxQQRQaqHSCcMOD02gNls4NNjnzC8DVVu8Cu9NqoD6mAPTQ2BHWqCZV5sAKyctrJbYvb7X1aRPvc5/VgQl/Y9gdYpoX7tX+N0L9NMN42PUnICmSejvNkFA6U9VOQcahEbXAvwiDShgu50nUn5uG8xpXkDBoltUPSi+MQlKiZn5lpuY0gswh9U8JVmC+QRqwbXqCB20hpF25PZXrYB31aHYmjCZogM/8k3eAi83/Uytah7n/QcWLne2sWkrlLCAWrtopfY3p2uZm330Xz1D shreyas@Shreyas-MacBook-Pro.local

ops clinic duty checklist

Please note we need to have a few things for this request to be fully vetted:

  • - wikitech username and preferred shell username
  • - public key from user
  • - @shrlak needs to read and sign the L3 document. - Signed on Fri, Feb 24, 20:48.
  • - @RStallman-legalteam confirmed NDA on file.
  • - someone at WMF should sponsor/approve this request as the WMF manager/contact person. Discussion with @Jgreen shows that Lisa Gruwell approved similar access for fundraising, so @RobH emailed Lisa for this approval on 2017-02-24
  • - 3 business day wait for any objections to be noted on task. This ends on 2017-03-01.

Patchset: https://gerrit.wikimedia.org/r/339686

Event Timeline

shrlak created this task.Feb 24 2017, 6:07 PM
Restricted Application added a project: Operations. · View Herald TranscriptFeb 24 2017, 6:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
RobH added a subscriber: RobH.Feb 24 2017, 6:33 PM
This comment was removed by RobH.
RobH updated the task description. (Show Details)Feb 24 2017, 6:33 PM
RobH updated the task description. (Show Details)Feb 24 2017, 6:42 PM
RobH added a subscriber: RStallman-legalteam.
RobH removed Jgreen as the assignee of this task.Feb 24 2017, 6:51 PM
RobH updated the task description. (Show Details)
RobH added a subscriber: Jgreen.

@RobH: this is to confirm that @skrlak is under contract with us through CPS and has also signed a separate NDA. All set!

RobH updated the task description. (Show Details)Feb 24 2017, 7:04 PM
RobH updated the task description. (Show Details)Feb 24 2017, 7:22 PM
RobH updated the task description. (Show Details)Feb 24 2017, 7:35 PM

@RobH: right now contract is through 6/30/2017. Thanks!

Change 339686 had a related patch set uploaded (by RobH):
shell access for Shreyas Lakhtakia

https://gerrit.wikimedia.org/r/339686

RobH added a comment.Feb 24 2017, 8:03 PM

I forgot to note that typically we list someone to be notified when the expiry is hit (typically someone who can them confirm if the person needs to keep access or if it should be revoked.) Who is the best point of contact for that?

Right now I just listed Rachel as our legal contact, but I'm not sure if that is correct.

RobH updated the task description. (Show Details)Feb 24 2017, 8:04 PM

I verified Shreyas's SSH public key by Google (video) Hangout today.

ema triaged this task as Normal priority.Feb 27 2017, 12:59 PM
RobH added a comment.Feb 27 2017, 4:44 PM

Please note that I emailed Lisa Gruwell as the person to approve access, which she granted on 2017-02-24.

RobH updated the task description. (Show Details)Feb 27 2017, 4:45 PM
ema updated the task description. (Show Details)Mar 1 2017, 9:15 AM

Change 339686 merged by Ema:
shell access for Shreyas Lakhtakia

https://gerrit.wikimedia.org/r/339686

ema added a subscriber: ema.Mar 1 2017, 9:27 AM

No objections noted, account created. @shrlak please let us know if you encounter any access issues, otherwise we're good to close this task.

Ottomata closed this task as Resolved.Mar 6 2017, 5:56 PM
Ottomata claimed this task.

No objections since Wednesday, resoliving.