Page MenuHomePhabricator

Language search is not visible when beta is enabled
Closed, ResolvedPublic2 Estimated Story Points

Description

Steps to Reproduce:

  1. Navigate to a page (example - en.m.wikipedia.org)
  2. Login using an existing account
  3. Navigate to Settings and turn Beta features on
  4. View any article with multiple languages
  5. Tap the languages icon

Expected Result:
A list of available languages appears with a search entry field at the top for searching languages.

Actual Result:
No search appears

Systems details:
Galaxy S5 Android 4.4 - Chrome 35
Pixel Android 7.1 - Chrome 52
iPhone 6S iOS 9 - Safari 9.0

Event Timeline

Restricted Application added a subscriber: Aklapper. ยท View Herald TranscriptFeb 24 2017, 11:49 PM

Change 339801 had a related patch set uploaded (by Pmiazga):
Hide header_v2 .search-box oly when it's inside header

https://gerrit.wikimedia.org/r/339801

I'm not sure if my patch fixes the problem as I cannot test it locally yet - please test it first (you need multilang support)

ovasileva moved this task from Incoming to 2016-17 Q3 on the Readers-Web-Backlog board.
MBinder_WMF set the point value for this task to 2.Feb 27 2017, 6:09 PM
MBinder_WMF added subscribers: phuedx, MBinder_WMF.

@phuedx to create a follow up tech debt task. This one needs a quick and dirty fix for now.

Change 339801 merged by jenkins-bot:
Always show the .search-box inside language overlay

https://gerrit.wikimedia.org/r/339801

This appears to be fixed on Wikipedia beta.

This comment was removed by ovasileva.
This comment was removed by ovasileva.

Ah, nm, confirmed on beta cluster