Page MenuHomePhabricator

Segmentation fault creating thumbnail
Closed, DeclinedPublic

Description

Opening the following URL leads to an error: https://upload.wikimedia.org/wikipedia/commons/thumb/2/2c/Map_of_Virginia_highlighting_Arlington_County.svg/145px-Map_of_Virginia_highlighting_Arlington_County.svg.png

The error is:

Error creating thumbnail: /usr/bin/timeout: the monitored command dumped core /srv/mediawiki/php-1.29.0-wmf.13/includes/limit.sh: line 101: 4773 Segmentation fault /usr/bin/timeout $MW_WALL_CLOCK_LIMIT /bin/bash -c "$1" 3>&-

Full request output follows.

> GET /wikipedia/commons/thumb/2/2c/Map_of_Virginia_highlighting_Arlington_County.svg/145px-Map_of_Virginia_highlighting_Arlington_County.svg.png HTTP/1.1
> Host: upload.wikimedia.org
> User-Agent: curl/7.49.1
> Accept: */*
>
< HTTP/1.1 500 Internal Server Error
< Date: Tue, 28 Feb 2017 16:15:03 GMT
< Content-Type: text/html; charset=utf-8
< Content-Length: 611
< Connection: keep-alive
< X-Content-Type-Options: nosniff
< X-Powered-By: HHVM/3.12.14
< Server: mw1293.eqiad.wmnet
< X-Mw-Thumbnail-Renderer: mw1293
< Cache-Control: no-cache
< P3p: CP="This is not a P3P policy! See https://commons.wikimedia.org/wiki/Special:CentralAutoLogin/P3P for more info."
< Backend-Timing: D=365232 t=1488298503370636
< X-Trans-Id: tx216724673b944720b7c4d-0058b5a207
< Vary: Accept-Encoding
< X-Varnish: 234804455, 36058188, 954963793
< Via: 1.1 varnish-v4, 1.1 varnish-v4, 1.1 varnish-v4
< Age: 0
< X-Cache: cp1074 miss, cp3036 miss, cp3045 pass
< X-Cache-Status: miss
< Strict-Transport-Security: max-age=31536000; includeSubDomains; preload
< X-Analytics: https=1;nocookies=1
< X-Client-IP: XXX.XXX.XXX.XXX
< Access-Control-Allow-Origin: *
< Access-Control-Expose-Headers: Age, Date, Content-Length, Content-Range, X-Content-Duration, X-Cache, X-Varnish
< Timing-Allow-Origin: *
<
<!DOCTYPE html>
<html><head>
<meta charset="UTF-8" />
<title>Error generating thumbnail</title>
</head>
<body>
<h1>Error generating thumbnail</h1>
<p>
Error creating thumbnail: /usr/bin/timeout: the monitored command dumped core
/srv/mediawiki/php-1.29.0-wmf.13/includes/limit.sh: line 101: 69972 Segmentation fault      /usr/bin/timeout $MW_WALL_CLOCK_LIMIT /bin/bash -c &quot;$1&quot; 3&gt;&amp;-

</p>
<!-- http://commons.wikimedia.org/w/thumb_handler.php/2/2c/Map_of_Virginia_highlighting_Arlington_County.svg/145px-Map_of_Virginia_highlighting_Arlington_County.svg.png -->
<!-- mw1293 -->

</body>
</html>
* Connection #0 to host upload.wikimedia.org left intact

Event Timeline

ema created this task.Feb 28 2017, 4:24 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 28 2017, 4:24 PM
Ottomata triaged this task as Medium priority.Mar 6 2017, 7:47 PM
Ramsey-WMF moved this task from Untriaged to Triaged on the Multimedia board.Nov 24 2017, 5:22 PM
Ebe123 added a subscriber: Ebe123.EditedAug 16 2019, 3:43 PM

Note that even though no error is shown, the image is not of Richmond City but of Richmond County, so this bug has not been resolved. See https://upload.wikimedia.org/wikipedia/commons/thumb/f/f0/Map_of_Virginia_highlighting_Richmond_City.svg/256px-Map_of_Virginia_highlighting_Richmond_City.svg.png (256px)

AntiCompositeNumber closed this task as Declined.May 15 2020, 4:43 AM

That's not a bug in the SVG rendering though, that's a problem with the SVG code itself. The SVG is being generated correctly on the modern thumbnailing infrastructure, so I'm closing this.