Page MenuHomePhabricator

RC filters - colored bullet points displayed overlapped
Closed, ResolvedPublic

Description

According to the spec on T149467: Build user interface for the Highlight Tools and implement highlighting in the Edit Results List

Highlighted items show a colored bullet point corresponding to the color of each highlighted property/filter that applies to the edit. Bullets are right aligned. Colors appear in the same order for each item (same order as in the color selector: blue, green, yellow, orange, and red).

Sometime the colored bullet points displayed overlapped. The screenshots below illustrate some cases. In each case I made sure that there are no highlighting left selected.

The most likely scenario to reproduce the issue:

  1. Click on 'Recent changes' link. The default filters will be displayed. Since overlapping bullet points are never displayed on the first load, the page will present lines preceded with bullet points - some of them blue and some of them green. This coloring belongs to the old behavior.

  1. Make sure that in Recent changes there are edits made by you. Select the filter 'Your own edits' and also select some highlighting for that filter. Your edits will be displayed with overlapping circles.

There are many more confusing cases:
No filters selected, no highlighting selected:


Close-up:

Additional colors is present as colored bullets point although they were not selected

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 4 2017, 12:51 AM

Change 341467 had a related patch set uploaded (by wikigit):
[mediawiki/core] RCFilters UI: Override 'list-style' for <li> results

https://gerrit.wikimedia.org/r/341467

Mooeypoo claimed this task.Mar 7 2017, 12:25 AM

This was caused due to a style in betalabs -- the commit is to try and protect against these individual styles, but we should really fix this in beta specifically.

Change 341467 merged by jenkins-bot:
[mediawiki/core] RCFilters UI: Override 'list-style' for <li> results

https://gerrit.wikimedia.org/r/341467

Checked in betalabs - the issue is resolved. All dots

QA recommendation: Resolve.

jmatazzoni closed this task as Resolved.Mar 8 2017, 2:29 AM