Page MenuHomePhabricator

netmon1002 networking setup
Closed, ResolvedPublic

Description

This task will track the network switch/router level setup of netmon1002.

This new system will replace netmon1001. As such, all of the special networking rules for netmon1001 will need to be duplicated and/or migrated to netmon1002.

At the time of this task's creation, netmon1002 is not yet on site. Since we don't have a network port assignment yet, there isn't likely any immediate action possible (other than looking and knowing what future work will need to apply.)

netmon1001 runs the following services, and netmon1002 will need to run them:

  • - rancid::server
  • - librenms
  • - servermon::wmf
  • - torrus
  • - smokeping

Each of these services need to be confirmed what special networking requirements they have, outside of the typical public ipv4 and ipv6 addresses. Eg: ganglia aggregators need router config changes.

Event Timeline

faidon moved this task from Backlog to Watching on the netops board.Apr 4 2017, 1:16 PM

netmon1002 is in rack a3 and is connected to ge-4/0/22 which has already been placed in the public vlan

Dzahn added a comment.May 2 2017, 12:51 AM

This is unblocked now since netmon1002 has been installed, and IPv6 has been configured (T159756#3226683)

netmon1002.wikimedia.org has address 208.80.154.5
netmon1002.wikimedia.org has IPv6 address 2620:0:861:1:208:80:154:5

Dzahn moved this task from Watching to Backlog on the netops board.May 2 2017, 12:51 AM
ayounsi closed this task as Resolved.May 2 2017, 8:21 AM
ayounsi claimed this task.

I don't see the IP or hostname of netmon1001 hardcoded in network devices.
DNS records for librenms.wikimedia.org will have to point to the new IP as it's the hostname used for syslog forwarding.
Other than that, no services seem to have a specific network requirement (see Ganglia bellow).

Per IRC conversation, Torrus might not have to move and be decommissioned instead (see T87840)
LibreNMS is being moved to Scap3 (see T129136), which might make it easier to migrate to netmon1002.
Per IRC conversation, Ganglia is used for the Torrus integration and can be decommissioned.

All services there are for monitoring so moving them will not have any user impact and can be done anytime.

akosiaris updated the task description. (Show Details)May 2 2017, 8:44 AM