1.29.0-wmf.15 regression: notification popup misaligned, partially off-screen in RTL
Closed, ResolvedPublic

Description

Hi. The new deployment moved the notices and alerts bubbles deep to the right side of window, making them unvisible and unreadable. I just sent two screenshots to the wikitech-l list, because I can't upload files from this browser. Thank you.

IKhitron created this task.Mar 8 2017, 11:10 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
IKhitron triaged this task as "Unbreak Now!" priority.Mar 8 2017, 11:10 PM
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptMar 8 2017, 11:10 PM

This is what I see, which doesn't look as terrible as what @IKhitron describes but does look pretty broken:

This comment was removed by IKhitron.
IKhitron added a comment.EditedMar 8 2017, 11:28 PM

Your screen just has more width than mine. See the bubble arrow on you screen, it's in wrong position. And please see the screenshots I sent.

Yes, if I narrow my screen the popup runs off-screen. I can't use the screenshots you sent because they never made it to wikitech-l.

I think I have found the cause of this bug, working on a fix now. Should be able to have it out in 30-60 minutes.

Change 341927 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/Echo] Fix RTL popup alignment for changes in 0.19.4

https://gerrit.wikimedia.org/r/341927

Thank you! About the files, I checked now, they wait for moderation.

Change 341931 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/Echo] Fix RTL popup alignment for OOjs UI 0.19.5

https://gerrit.wikimedia.org/r/341931

Change 341927 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/Echo] Fix RTL popup alignment for changes in 0.19.4

https://gerrit.wikimedia.org/r/341927

This is now scheduled for deployment at midnight UTC (in 15 minutes).

Catrope changed the title from "Today deployment made RTL notifications unvisible" to "1.29.0-wmf.15 regression: notification popup misaligned, partially off-screen in RTL".Mar 8 2017, 11:46 PM

Change 341931 merged by jenkins-bot:
[mediawiki/extensions/Echo] Fix RTL popup alignment for OOjs UI 0.19.5

https://gerrit.wikimedia.org/r/341931

Change 341927 merged by jenkins-bot:
[mediawiki/extensions/Echo] Fix RTL popup alignment for changes in OOjs UI 0.19.4

https://gerrit.wikimedia.org/r/341927

Mentioned in SAL (#wikimedia-operations) [2017-03-09T00:18:32Z] <catrope@tin> Synchronized php-1.29.0-wmf.15/extensions/Echo/modules/styles/mw.echo.ui.NotificationBadgeWidget.less: Fix RTL popup alignment (T159999) (duration: 00m 42s)

Vv. Thahk you very much for your help. It looks even better than before yesterday, when there was some shift of about 8 mm, and now it's exactly in the right place.

IKhitron closed this task as "Resolved".Mar 9 2017, 12:25 AM
IKhitron claimed this task.
IKhitron reassigned this task from IKhitron to Catrope.

Hello @Catrope and everyone, here are the screenshots: