Page MenuHomePhabricator

Client should handle default for 'string_options' groups
Closed, ResolvedPublic

Description

The backend already sends the default to the client.

The client should accept the 'default' field, and if that's omitted IMHO a safer default is '' (empty string, group has no effect).

Event Timeline

Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptMar 9 2017, 5:41 PM
Mattflaschen-Personal renamed this task from Handle default for 'string_options' groups to Client should handle default for 'string_options' groups.Mar 29 2017, 5:19 PM

Change 345444 had a related patch set uploaded (by Sbisson):
[mediawiki/core@master] RC Fitlers: correctly read default value for 'string_options' filters

https://gerrit.wikimedia.org/r/345444

Change 345444 merged by jenkins-bot:
[mediawiki/core@master] RC Filters: correctly read default value for 'string_options' filters

https://gerrit.wikimedia.org/r/345444

Checked as a part of regression testing on betalabs - all functionality seems to be in place.

Catrope closed this task as Resolved.May 3 2017, 11:38 PM