Page MenuHomePhabricator

Build time regression for ext.wikimediaBadges
Closed, InvalidPublic

Description

https://grafana.wikimedia.org/dashboard/db/resourceloadermodule?var-module=ext_wikimediaBadges

Regression became visible immediately after the 1.29.0-wmf.14 roll out to group2 on 2017-03-02

20:05 demon@tin: rebuilt wikiversions.php and synchronized wikiversions files: group2 to wmf.14


p95 went from 5ms to 15ms. Minutely max went from wiggling between 500ms-1s to being between 1s-1.5s.

This is especially notable because this happened in the same release that also fixed T158813 which universally improved build times for the majority of modules, and yet this one regressed somehow - quite consistently and significantly so.

Event Timeline

Krinkle created this task.Mar 10 2017, 1:39 AM
Krinkle updated the task description. (Show Details)

Looking back a bit further:
https://grafana.wikimedia.org/dashboard/db/resourceloadermodule?var-module=ext_wikimediaBadges&panelId=27&fullscreen&from=1487193805051&to=1489110251332

It seems the weekly max is actually coming down week over week, but looking at the green lines in the bottom it's clear that were once there was a lot of breathing room in the 0-1s area, it's now consistently filling up that area and never coming below 1s.

Krinkle closed this task as Invalid.Mar 21 2017, 3:59 AM

Seems unrelated to this module and mostly evened out. Whatever it was, most likely something related to DB responsiveness in general.