Page MenuHomePhabricator

Unusable scrollbar shown in dialog to edit <syntaxhightlight> in VE
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce (in Firefox):

  1. Go to https://de.wikipedia.org/wiki/Element_(Auszeichnungssprache)?veaction=edit.
  2. Edit the second syntaxhighlight-element in the section "HTML (Version 1 bis 4)"
  3. Note there is an "i" left of the first line of code (probably it wants to inform me about the unclosed tag).
  4. Hover over this "i". Note that a scrollbar on the dialog is shown (perhaps some more information about the fact that the tag is unclosed is shown below).
  5. Try to scroll. Once you start scrolling, you stop hovering, and the scrollbar vanishes.

In Vivaldi, in step 4 no scrollbar appears, nor does happen anything else. If hovering over the "i" is meant to show additional information, this is equally bad, and makes the "i" useless in complex situations.

Event Timeline

Schnark created this task.Mar 11 2017, 9:36 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptMar 11 2017, 9:36 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

This is due to ace editor's poor implementation of a tooltip which follows the mouse. It doesn't play nicely inside the absolutely positioned dialog overlay. Without an upstream code fix we'll probably have to do a CSS hack.

Change 342871 had a related patch set uploaded (by Esanders):
[mediawiki/extensions/VisualEditor] Fix position of ace tooltip

https://gerrit.wikimedia.org/r/342871

Jdforrester-WMF closed this task as Resolved.Mar 15 2017, 5:55 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Jdforrester-WMF removed a project: Patch-For-Review.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 15 2017, 5:55 PM

Change 342871 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor] MWAceEditorWidget: Fix position of ace tooltip

https://gerrit.wikimedia.org/r/342871